F55/F56 :: Hatch Talk (2014+) MINI Cooper and Cooper S (F55/F56) hatchback discussions.
Sponsored by:
Sponsored by:

Mini coding/programming

  #926  
Old 01-22-2019, 02:15 PM
orangedrink888
orangedrink888 is offline
1st Gear
Join Date: Aug 2018
Posts: 25
Received 0 Likes on 0 Posts
Disable Front Parking Lights?

Anyone know the coding to disable the front parking lights?
 
  #927  
Old 03-09-2019, 02:11 PM
ghstrdr's Avatar
ghstrdr
ghstrdr is offline
1st Gear
Join Date: Sep 2011
Location: Pflugerville, Texas
Posts: 35
Received 1 Like on 1 Post
Originally Posted by JosephM635 View Post

I can confirm that this coding works for the:

JCW Tach and Gear Selection in HUD

HU_NBT > EXPERT MODE > HUD_SPORTANZEIGE_ENABLE, HUD_SPORTANZEIGE_FES_ENABLE, and HUD_SPORTANZEIGE_MS_GASSE_ENABLE to AKTIV.

Code

Then
KOMBI > EXPERT MODE > FZG_Aussttang,HUD _SPORTANZEIGE_ENABLE, HUD_SPORTANZEIGE_FES_ENABLE, and HUD_SPORTANZEIGE_MS_GASSE_ENABLE to AKTIV.

Code


So Cool!

I had to cycle the ignition twice to get rid of the error message.

What driving mode were you in when you took this picture? I believe that this is factory for sport mode on JCW's with the HUD but am interested if this activates it for all driving modes.
 
  #928  
Old 03-09-2019, 02:30 PM
JosephM635
JosephM635 is offline
1st Gear
Join Date: Apr 2018
Posts: 13
Likes: 0
Received 2 Likes on 2 Posts
Originally Posted by ghstrdr View Post
What driving mode were you in when you took this picture? I believe that this is factory for sport mode on JCW's with the HUD but am interested if this activates it for all driving modes.
Once Coded, this works in every driving mode on my 2015 Cooper S F56.
 
  #929  
Old 03-13-2019, 05:41 AM
sgscomps's Avatar
sgscomps
sgscomps is offline
3rd Gear
Join Date: Jul 2013
Posts: 240
Likes: 0
Received 2 Likes on 2 Posts
I coded the JCW tach in my HUD, it’s in the same location as my NAV directions so now my NAV doesn’t display. Is there a way to move the tach to the other side of the HUD so both are present?
 
  #930  
Old 03-13-2019, 06:04 AM
emulajavi
emulajavi is offline
1st Gear
Join Date: Aug 2015
Posts: 17
Received 1 Like on 1 Post
Originally Posted by sgscomps View Post
I coded the JCW tach in my HUD, it’s in the same location as my NAV directions so now my NAV doesn’t display. Is there a way to move the tach to the other side of the HUD so both are present?
Sadly it seems that’s the default behavior is that: if you enable the JCW tach on the HUD settings, the NAV directions do not display at all. You have to have the JCW tach disabled, and so, only the speed shown with a ‘blank space’ to the right to get the NAV directions to show on that ‘blank space’.


The logical behavior would be to always show NAV directions (if NAV directions are activated on HUD settings) no matter if the Sports displays - JCW tacho is activated or not in that settings.
 
  #931  
Old 03-13-2019, 06:45 PM
sgscomps's Avatar
sgscomps
sgscomps is offline
3rd Gear
Join Date: Jul 2013
Posts: 240
Likes: 0
Received 2 Likes on 2 Posts
I was hoping to be able to have both at the same time. I'll try turning off the JCW tach in settings and see if the nav comes back. I can always turn the tach off when I want to use nav for trips.
 
  #932  
Old 03-24-2019, 02:07 PM
callumensor
callumensor is offline
Neutral
Join Date: Mar 2019
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Indicators as DRLS

Hi does anyone know how to code the indicators as the drls, so I have a amber light constantly on when drls are on.
cheers
 
  #933  
Old 03-29-2019, 09:33 AM
Banner28's Avatar
Banner28
Banner28 is offline
1st Gear
Join Date: Jun 2015
Location: Austin Area
Posts: 26
Received 1 Like on 1 Post
Hopefully this is the proper place for posting this. Does anyone know the codes to keep the "Angel Eye Halo's" on with the fog lights when placed in the Parking Lights toggle position. I can code the fog lights on with DRL's so that the full fog light is lit up in parking light position. However, after my ECU got reset by the factory, I cannot seem to get the Halo to stay on with the fog lights. Example of how my car used to be below
 
  #934  
Old 04-04-2019, 02:41 PM
DunkM's Avatar
DunkM
DunkM is offline
3rd Gear
Join Date: Nov 2015
Location: Atlanta, GA
Posts: 264
Received 11 Likes on 11 Posts
Just an update for everyone, I have updated the first post in the "Union Jack" thread to cover physical install, coding removal of the errors, and changes to both the US lights for correctly working the turn signal during braking and the EU lights for correctly working brake force display.
 
The following users liked this post:
curlywurly (04-05-2019)
  #935  
Old 04-13-2019, 10:02 AM
Asssuuu!!!
Asssuuu!!! is offline
Neutral
Join Date: Apr 2019
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Looking for some coding guidance to turn off the welcome gongs/chime, what would be the code? I just hate that bee-bop bee-bop sound every time the car started. What is it under?

Also, I tried to do the accoustic confirmation upon locking/unlocking the car. The checkbox succesfully appeared on the idrive system but it does not do anything. What gives? The 2015MCS simply does not have the small beep speaker?

Succesfully added the JCW tach, roll up all windows by holding the lock button.
 
  #936  
Old 04-13-2019, 12:15 PM
vetsvette's Avatar
vetsvette
vetsvette is offline
Moderator
iTrader: (5)
Join Date: Oct 2013
Location: South Central Virginia
Posts: 3,763
Received 354 Likes on 281 Posts
You won't get the confirmation beep unless you have the factory alarm system. The gong/chime should be in the shortcut menu. It's been a long time since I coded mine out.
 
  #937  
Old 04-13-2019, 09:27 PM
Asssuuu!!!
Asssuuu!!! is offline
Neutral
Join Date: Apr 2019
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
thanks, i was able to remove the welcome gongs. It was under seat belt reminder...

Too bad, it seems i do not have an alarm system.
 
  #938  
Old 04-13-2019, 10:13 PM
vetsvette's Avatar
vetsvette
vetsvette is offline
Moderator
iTrader: (5)
Join Date: Oct 2013
Location: South Central Virginia
Posts: 3,763
Received 354 Likes on 281 Posts
Originally Posted by Asssuuu!!! View Post
thanks, i was able to remove the welcome gongs. It was under seat belt reminder...

Too bad, it seems i do not have an alarm system.
I was disappointed when I couldn't get the confirmation beep too. Old ears don't always hear the locks click in a busy area.
 
  #939  
Old 04-18-2019, 04:45 PM
curlywurly's Avatar
curlywurly
curlywurly is offline
1st Gear
Join Date: Dec 2018
Location: British Columbia, Canada
Posts: 19
Received 8 Likes on 5 Posts
Coding LCI analog clock to the central screen display?

Image below to illustrate. I recently noticed the 'home' or dormant screen on LCI's has a sweet analog clock display, with date below.


Anyone stumbled on coding options for this?
 
  #940  
Old 04-19-2019, 11:29 AM
N0B0DY
N0B0DY is offline
3rd Gear
Join Date: Sep 2018
Posts: 213
Received 42 Likes on 35 Posts
That's just the screen saver. Not sure if it's in the older system;
 
  #941  
Old 04-23-2019, 06:23 AM
xentar's Avatar
xentar
xentar is offline
2nd Gear
Join Date: Jun 2017
Location: Oshawa, Ontario
Posts: 69
Received 5 Likes on 4 Posts
Originally Posted by vetsvette View Post
I was disappointed when I couldn't get the confirmation beep too. Old ears don't always hear the locks click in a busy area.
Same here.. Although you can code the car to sound the horn when you lock the doors while the engine is running. I hope there is a way to code the same when the engine is off.
 
  #942  
Old 04-23-2019, 02:24 PM
Warren2185
Warren2185 is offline
1st Gear
Join Date: Oct 2018
Posts: 30
Received 0 Likes on 0 Posts
Bimmercode could not access my head unit to turn off the legal disclaimers that come up every start-up. I'm bummed.

I have a 2019 JCW 3 dr without the navigation. So it's a 6.5 display with no touchscreen. But it has Mini Connect and everything else Anyone had any luck with another coder, Esys?
 
  #943  
Old 04-23-2019, 04:38 PM
Sansho's Avatar
Sansho
Sansho is offline
1st Gear
Join Date: Jan 2019
Posts: 14
Received 4 Likes on 4 Posts
Bimmercode could not access my head unit to turn off the legal disclaimers that come up every start-up. I'm bummed.

I have a 2019 JCW 3 dr without the navigation. So it's a 6.5 display with no touchscreen. But it has Mini Connect and everything else Anyone had any luck with another coder, Esys?
Have you contacted the BiimmerCode author about this? It worked on my 2018 MCS.
 
  #944  
Old 04-23-2019, 04:53 PM
Warren2185
Warren2185 is offline
1st Gear
Join Date: Oct 2018
Posts: 30
Received 0 Likes on 0 Posts
Originally Posted by Sansho View Post
Have you contacted the BiimmerCode author about this? It worked on my 2018 MCS.
Yes, Bimmercode replied to my email...."that head unit is not supported at this time"

Sansho, was your 2018 the non-touch screen 6.5" display? It does appear the 8.8 Navigation/Touchscreen in the 2019 definitely is supported.
 
  #945  
Old 04-23-2019, 10:05 PM
N0B0DY
N0B0DY is offline
3rd Gear
Join Date: Sep 2018
Posts: 213
Received 42 Likes on 35 Posts
Originally Posted by Warren2185 View Post
Yes, Bimmercode replied to my email...."that head unit is not supported at this time"

Sansho, was your 2018 the non-touch screen 6.5" display? It does appear the 8.8 Navigation/Touchscreen in the 2019 definitely is supported.
He told me the same thing too. We need more people to request this for the 6.5” display.
 
The following users liked this post:
Warren2185 (04-24-2019)
  #946  
Old 04-25-2019, 06:34 AM
Sansho's Avatar
Sansho
Sansho is offline
1st Gear
Join Date: Jan 2019
Posts: 14
Received 4 Likes on 4 Posts
Yes, Bimmercode replied to my email...."that head unit is not supported at this time"

Sansho, was your 2018 the non-touch screen 6.5" display? It does appear the 8.8 Navigation/Touchscreen in the 2019 definitely is supported.
Mine has the 8.8" display.
 
  #947  
Old 04-26-2019, 03:56 PM
Sansho's Avatar
Sansho
Sansho is offline
1st Gear
Join Date: Jan 2019
Posts: 14
Received 4 Likes on 4 Posts
Hmm, thought I replied to this, but don't see it ... I have the 8.8" navigation display on my 2018.
 
  #948  
Old 05-17-2019, 12:52 AM
axman207
axman207 is offline
Neutral
Join Date: May 2019
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Hello I have a 2015 cooper s with the factory jcw package on it but want to remove fog lights to convert it to jcw look. After I do this I would get error codes with the removal of the fog lights and also the sidelights would need to be changed from the fog lights to the headlights. Thank you very much guys and hope someone can help
 
  #949  
Old 05-17-2019, 07:44 PM
artmem
artmem is offline
2nd Gear
Join Date: Dec 2008
Location: Chicago, Illinois
Posts: 86
Likes: 0
Received 0 Likes on 0 Posts
I recently used Bimmercode to enable the rear fog lights in my 2019 F56 S. They work fine, but since then, I regularly get warnings that my rear brake lights and rear turn signals are malfunctioning (they aren’t). Sometimes it goes away if I restart the car, and sometimes ithe warning stays for a few days and then goes away. Any ideas wha might be causing this?
 
  #950  
Old 05-17-2019, 07:46 PM
TVPostSound
TVPostSound is offline
6th Gear
iTrader: (3)
Join Date: Mar 2014
Location: Granada Hills, CA
Posts: 1,497
Received 136 Likes on 124 Posts
Originally Posted by artmem View Post
I recently used Bimmercode to enable the rear fog lights in my 2019 F56 S. They work fine, but since then, I regularly get warnings that my rear brake lights and rear turn signals are malfunctioning (they aren’t). Sometimes it goes away if I restart the car, and sometimes ithe warning stays for a few days and then goes away. Any ideas wha might be causing this?
Did you get the right headlamp switch?
 

Thread Tools
Search this Thread
Quick Reply: Mini coding/programming


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.