Issue with JCW Pro Exhaust

  #1  
Old 06-14-2018, 07:50 AM
RLM
RLM is offline
2nd Gear
Thread Starter
Join Date: Jan 2014
Posts: 88
Likes: 0
Received 8 Likes on 8 Posts
Issue with JCW Pro Exhaust

I recently picked up a '16 JCW that had the pro exhaust installed by the dealer for the previous owner. I absolutely love the exhaust and the sound (when valve is open), however, I believe it is not functioning correctly.

after opening the valve (double click button and led ring flashes red), while driving, the ring will blink red (one blink every so often) and it sounds like the valve has closed itself, however, when i giv'er, the valve is definitely open. as well, sometimes ( cannot figure out a distinct pattern) the valve will close itself and needs the double click to open back up. the other day it closed itself about every 30 seconds on my short across town drive. was quite annoying.

I drive almost exclusively with the valve open as I find the valve closed makes the car quieter than even a stock JCW exhaust. it is my understanding that i should be able to click the button and it stay open for the duration of the trip unless i deliberately close it with the button again. I do understand tho that after shutting the car down, the valve will "time out" and close itself.

I talked to one of the local dealers and they said it should not be doing it and that it would need to be diagnosed what the issue is and if an issue is found, would be covered by warranty. my issue is that on most drives it behaves as expected, so I'm worried that it will function correctly during the diagnostic and I will be charged and will accomplish nothing.

Has anyone else experienced this or is this normal operation? does the valve close if exhaust gets too hot?
 
  #2  
Old 06-14-2018, 09:56 AM
TheBigNewt
TheBigNewt is offline
OVERDRIVE
Join Date: Mar 2007
Location: Arizona
Posts: 5,199
Likes: 0
Received 20 Likes on 19 Posts
I obviously don't have one, but I remember people posting here some time back about similar problems. I remember somebody got theirs "fixed" so it was open all the time and they liked it that way.
 
  #3  
Old 06-14-2018, 10:03 AM
RLM
RLM is offline
2nd Gear
Thread Starter
Join Date: Jan 2014
Posts: 88
Likes: 0
Received 8 Likes on 8 Posts
Yea, I saw that you can open the valve, then disconnect from the module and it won't close, but I'd like to have the option to close it. Keeps the neighbours in the complex happy at 5:30 am
 
  #4  
Old 06-14-2018, 10:16 AM
vetsvette's Avatar
vetsvette
vetsvette is online now
Moderator
iTrader: (5)
Join Date: Oct 2013
Location: South Central Virginia
Posts: 3,763
Received 354 Likes on 281 Posts
This is a well known problem with this system. Some people experience it while others don’t, or it just happens with varying degrees of annoyance. I traced the problem with mine to my Apple Watch. When wearing it the exhaust system seemed to have a mind of it’s own. Since I, like you, preferred it open all the time I just unplugged the wiring harness located inside the inspection panel on the passenger side of the boot. Panel pops right out and you can see the BT module. Start the car, open the valve with the fob, and while it’s open just unplug the large connector on the BT module. This will keep the valve open at all times. I ran mine like this until I installed my cat less DP. Way too loud to leave open all the time so I plugged the harness back in and it is once again controlled by the Fob. I just quit wearing the Apple Watch and have only had it malfunction once or twice in the last couple months. I attribute those to unknown outside influences. Mini_vinnie has pictures if this procedure on his website. Www.myredmini.com
 

Last edited by vetsvette; 06-14-2018 at 10:22 AM.
The following 2 users liked this post by vetsvette:
bratling (05-21-2019), Mini_Vinnie (06-15-2018)
  #5  
Old 06-15-2018, 05:46 AM
Mini_Vinnie's Avatar
Mini_Vinnie
Mini_Vinnie is offline
Moderator
iTrader: (1)
Join Date: Feb 2016
Location: Minneapolis, MN
Posts: 1,493
Received 213 Likes on 175 Posts
Originally Posted by vetsvette View Post
Mini_vinnie has pictures if this procedure on his website. Www.myredmini.com
Thanks buddy!!

Its been an issue for many of us. Ive heard things like the Apple Watch's blue tooth closing it, other cars BT etc...

Just do this and never have to worry about it again. It takes about a minute to do - https://myredmini.com/how-to-keep-yo...kit-always-on/
 
  #6  
Old 06-15-2018, 05:52 AM
RLM
RLM is offline
2nd Gear
Thread Starter
Join Date: Jan 2014
Posts: 88
Likes: 0
Received 8 Likes on 8 Posts
I've seen this "solution" however i do like being able to close the valve when necessary. the car is in for scheduled maintinence on Tuesday so I will bring it up with the dealer at that point. I will see if I can get them to replace the module and remote under warranty ( leather on the remote is peeling off from being inserted into the foam cupholder holder anyways). if they will not cover under warranty I will devise another solution to this problem, as well as be a headache for MINI Canada over the issue.
 
  #7  
Old 06-15-2018, 06:16 AM
Mini_Vinnie's Avatar
Mini_Vinnie
Mini_Vinnie is offline
Moderator
iTrader: (1)
Join Date: Feb 2016
Location: Minneapolis, MN
Posts: 1,493
Received 213 Likes on 175 Posts
Good luck, hopefully they can figure soemhting out.

Over here, Mini just says they cant replicate it
 
  #8  
Old 06-15-2018, 06:19 AM
RLM
RLM is offline
2nd Gear
Thread Starter
Join Date: Jan 2014
Posts: 88
Likes: 0
Received 8 Likes on 8 Posts
Sounds like the typical "we know about the issue but don't want to pay to develop a fix" excuse.
 
  #9  
Old 06-15-2018, 11:58 AM
RLM
RLM is offline
2nd Gear
Thread Starter
Join Date: Jan 2014
Posts: 88
Likes: 0
Received 8 Likes on 8 Posts
Not sure if anyone has stumbled onto this yet, but the M Performance Exhaust seems to use the same system ( remote is even the same minus the colours), and low and behold, same issues being reported there as well.

https://f87.bimmerpost.com/forums/sh....php?t=1319784

Just maybe if the M-car owners are complaining of this issue as well, BMW will work on a solution. they may not care about us MINI owners, but I bet they care a bit about their M clients
 
  #10  
Old 06-15-2018, 12:09 PM
MomMini's Avatar
MomMini
MomMini is offline
3rd Gear
Join Date: May 2012
Location: Naperville, IL
Posts: 158
Received 18 Likes on 15 Posts
I picked up a 2019 LCI JCW with exhaust and I am having the same issue. I found the original thread back from 2016 and nobody had an "official fix". I took it to dealer and they said that the reset software but it still turns off at random times. I do not want to keep flat open all the time but it may come down to that.

I wear an apple watch. Think I will spend the next few days not wearing it and see if there is any change.
 
  #11  
Old 06-17-2018, 04:32 AM
KYDan's Avatar
KYDan
KYDan is offline
4th Gear
Join Date: Sep 2012
Location: Frankfort Kentucky USA
Posts: 442
Received 15 Likes on 13 Posts
I suppose I have been lucky with this. I had the JCW performance exhaust installed in March of 2016 and have never had any issues with it. I am still using the original battery in it as well, and I drive with it on about 90% of the time. However, I don't have a blue tooth anything either.
 
  #12  
Old 07-06-2018, 09:38 PM
nicholascanada
nicholascanada is offline
Neutral
Join Date: Jul 2018
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
How do you know which one is the exhaust control module to pull out? Is there only one back there?
 
  #13  
Old 07-07-2018, 01:49 AM
kfmuller
kfmuller is offline
4th Gear
Join Date: Jul 2002
Location: Dallas, TX
Posts: 445
Received 10 Likes on 8 Posts
My 2016 JCW with the Pro exhaust is at the dealer right now because of the flap issue. It's been doing it for the last couple of years since I installed it. I thought they were already working on a fix for this, but had to bring it back in so that they could open a PUMA case on mine. The tech experienced 2 random flap closings in a couple of minutes, so at least they know it's not my imagination. They are replacing the module on mine - currently waiting on the part. It's where everything plugs in and is located in the trunk / rear fender area. I'll post here whether the fix works or not.
 
  #14  
Old 07-07-2018, 08:40 AM
vetsvette's Avatar
vetsvette
vetsvette is online now
Moderator
iTrader: (5)
Join Date: Oct 2013
Location: South Central Virginia
Posts: 3,763
Received 354 Likes on 281 Posts
Mine has worked fine since I stopped wearing my Apple Watch.

Looking in the boot area you will notice an access panel on your right (passenger side). Pop that off and the module is mounted right inside. There is one large plug that you need to pull if you want the flap open all the time. Just remember, you have to start the car and open the flap before pulling the plug. The position that the flap is in when you pull the plug is the one it will stay in.
I had mine open all the time until I installed my cat less DP. Need to be able to tone it down at times now.
 
  #15  
Old 07-07-2018, 08:59 PM
rtowell's Avatar
rtowell
rtowell is offline
3rd Gear
Join Date: Apr 2016
Location: Merritt Island, FL
Posts: 228
Likes: 0
Received 20 Likes on 16 Posts
No such issues with the Remus
 
  #16  
Old 07-08-2018, 03:04 AM
kfmuller
kfmuller is offline
4th Gear
Join Date: Jul 2002
Location: Dallas, TX
Posts: 445
Received 10 Likes on 8 Posts
Looks like I'll get mine back Monday - we'll see if new module does the trick
 

Last edited by kfmuller; 07-08-2018 at 03:11 AM.
  #17  
Old 07-09-2018, 06:18 AM
Mini_Vinnie's Avatar
Mini_Vinnie
Mini_Vinnie is offline
Moderator
iTrader: (1)
Join Date: Feb 2016
Location: Minneapolis, MN
Posts: 1,493
Received 213 Likes on 175 Posts
Originally Posted by vetsvette View Post
Mine has worked fine since I stopped wearing my Apple Watch.

Looking in the boot area you will notice an access panel on your right (passenger side). Pop that off and the module is mounted right inside. There is one large plug that you need to pull if you want the flap open all the time. Just remember, you have to start the car and open the flap before pulling the plug. The position that the flap is in when you pull the plug is the one it will stay in.
I had mine open all the time until I installed my cat less DP. Need to be able to tone it down at times now.
Here you go - https://myredmini.com/how-to-keep-yo...kit-always-on/
 
  #18  
Old 07-09-2018, 06:31 AM
kfmuller
kfmuller is offline
4th Gear
Join Date: Jul 2002
Location: Dallas, TX
Posts: 445
Received 10 Likes on 8 Posts
Yeah - I've done the keep it open all the time thing for the last year. But, I want it to work as it is supposed to. And, I want it fixed under warranty, so I made sure I was documenting the issue at the dealer over the last year. Mine does the random flap closing well before I got an Apple watch, and even if I turned off the Bluetooth on my phone. It seems I get other interference that causes issues from living in the downtown area of my city. I get far fewer - if any - flap closing when I'm out in the country or less congested areas.
 
  #19  
Old 07-10-2018, 12:48 PM
CarFreak427's Avatar
CarFreak427
CarFreak427 is offline
3rd Gear
Join Date: Apr 2013
Posts: 167
Received 26 Likes on 20 Posts
We have successfully stopped this problem on at least one car I know of by ordering and replacing the Bluetooth controller here at my dealer.
 
  #20  
Old 07-10-2018, 01:19 PM
kfmuller
kfmuller is offline
4th Gear
Join Date: Jul 2002
Location: Dallas, TX
Posts: 445
Received 10 Likes on 8 Posts
Originally Posted by CarFreak427 View Post
We have successfully stopped this problem on at least one car I know of by ordering and replacing the Bluetooth controller here at my dealer.
So far the fix has worked for me. The service order says the Bluetooth receiver's firmware was out of date, so they replaced the receiver, and paired the remote. I drove all the way home without issues. Apple Watch and iPhone X were connected via Bluetooth, and phone connected to car via Bluetooth. Drove normal route around interference downtown Dallas, and no issues. I'm optimistic that the fix worked.
 
  #21  
Old 07-10-2018, 01:27 PM
ECSTuning's Avatar
ECSTuning
ECSTuning is online now
Platinum Sponsor
Join Date: Jan 2013
Location: Wadsworth,OH
Posts: 27,715
Received 556 Likes on 536 Posts
Looks like the new firmware update to the system has been working from what I have heard.
 
__________________

Have MINI questions? Need MINI answers? Live Chat us! 8:30am to 12:00am Midnight EST
[email protected] | [email protected] | INSTAGRAM | FACEBOOK
Customer Service Hours: 8:00 AM to 8:00 PM EST|Sales Team Hours: 8:00 AM to 11:00 PM | Saturday 10AM to 7PM EST 800.924.5172
  #22  
Old 07-10-2018, 08:55 PM
uslfcfan's Avatar
uslfcfan
uslfcfan is offline
2nd Gear
Join Date: Jan 2016
Location: Atlanta
Posts: 95
Received 0 Likes on 0 Posts
Getting this system this Friday. How do I tell if mine has updated firmware? What should I ask my service tech?
 
  #23  
Old 07-11-2018, 05:22 AM
ECSTuning's Avatar
ECSTuning
ECSTuning is online now
Platinum Sponsor
Join Date: Jan 2013
Location: Wadsworth,OH
Posts: 27,715
Received 556 Likes on 536 Posts
Yep,
I would have them read it and flash it. I heard that the newest ones in stock had the firmware update. But its hard to tell stock without seeing manufacture date and knowing the date.
 
__________________

Have MINI questions? Need MINI answers? Live Chat us! 8:30am to 12:00am Midnight EST
[email protected] | [email protected] | INSTAGRAM | FACEBOOK
Customer Service Hours: 8:00 AM to 8:00 PM EST|Sales Team Hours: 8:00 AM to 11:00 PM | Saturday 10AM to 7PM EST 800.924.5172

Last edited by ECSTuning; 04-11-2019 at 10:48 AM.
  #24  
Old 07-11-2018, 07:11 AM
uslfcfan's Avatar
uslfcfan
uslfcfan is offline
2nd Gear
Join Date: Jan 2016
Location: Atlanta
Posts: 95
Received 0 Likes on 0 Posts
Any idea of the firmware version that is newest so I can tell my service tech.? Thank you again!
 
  #25  
Old 07-11-2018, 07:29 PM
MomMini's Avatar
MomMini
MomMini is offline
3rd Gear
Join Date: May 2012
Location: Naperville, IL
Posts: 158
Received 18 Likes on 15 Posts
I have been having issue even after dealer did a software update. Am taking car back in on friday to see about having controller replaced. Miniusa called me this asking about my new car purchase and i told them about this issue. I am hoping that they will back me up with the dealer to get this resolved.
 

Thread Tools
Search this Thread
Quick Reply: Issue with JCW Pro Exhaust


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: