Electrical For discussions regarding wiring up electrical modifications such as radar detectors, brake light mods, power sockets, and driving lights in Clubman (R55), Cooper and Cooper S (R56), and Cabrio (R57) MINIs.

NCSExpert for beginners

  #26  
Old 05-05-2011, 02:26 PM
alwzopn's Avatar
alwzopn
alwzopn is offline
3rd Gear
iTrader: (2)
Join Date: Sep 2010
Posts: 227
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by threar View Post
The entire datens download is 13GB total (34GB uncompressed). The R56 specific files are 2.7GB total. I'll send you a PM and see how we can get moving forward.
GB? As in gigabytes?!

Did they get suddenly bigger or was this a typo?
 
  #27  
Old 05-07-2011, 05:56 AM
threar
threar is offline
4th Gear
Join Date: Jul 2010
Location: Boulder, CO
Posts: 379
Likes: 0
Received 1 Like on 1 Post
The v41 I've got is the complete set (which amounts to 3 DVDs I believe) for all the BMW and MINI line. I've noticed in the r56 directory that not only is there daten, ecu and sgdat, but also cfgdat, data, format and kmmData. The most interesting to me is the data directory (which cfgdat has .ini files that reference it).

I just need to figure out how to make it all piece together.
 
  #28  
Old 05-18-2011, 03:57 PM
Yzo
Yzo is offline
2nd Gear
Join Date: Mar 2008
Location: San Jose, CA
Posts: 71
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by threar View Post
The v41 I've got is the complete set (which amounts to 3 DVDs I believe) for all the BMW and MINI line. I've noticed in the r56 directory that not only is there daten, ecu and sgdat, but also cfgdat, data, format and kmmData. The most interesting to me is the data directory (which cfgdat has .ini files that reference it).

I just need to figure out how to make it all piece together.
Could you 7z/Zip/Rar/whatever the R56 directory and share it somehow? No one seems to have posted just that chassis anywhere.
 
  #29  
Old 05-23-2011, 06:57 PM
GTECKO's Avatar
GTECKO
GTECKO is offline
3rd Gear
Thread Starter
Join Date: Feb 2011
Location: Halifax - Canada
Posts: 266
Likes: 0
Received 5 Likes on 1 Post
One 1st page, the download has been updated...have you checked it ??
 
  #30  
Old 05-24-2011, 04:00 PM
rotadent
rotadent is offline
2nd Gear
Join Date: Apr 2009
Location: Irvine, CA
Posts: 68
Likes: 0
Received 0 Likes on 0 Posts
Hi All,

First I want to say thanks for uploading everything and writing up the instruction manual, GTECKO.

I'm having some issues with the car after I installed some of the ECU changes. I installed the one touch sunroof and that seems to be working fine now. It wasn't for the first few times, but now it seems OK. I also installed the always show digital speed change and that went without a hitch.

I am having problems with the close windows with fob. When I open the windows and sunroof, the sunroof only tilts. Isn't it supposed to open all the way? It does close completely though.

Also, what bugs me most, is every time I shut the car down, there is a really annoying "grinding-clicking" sound that lasts for about 3 seconds. I think it's the same type of sound that you get when you are programming the ECU. But I'm not programming it now! I don't have the usb cable or the laptop plugged in.

Anyone else have this problem or can shed some light on this? I'm running v38 datens.
 
  #31  
Old 05-24-2011, 04:14 PM
GTECKO's Avatar
GTECKO
GTECKO is offline
3rd Gear
Thread Starter
Join Date: Feb 2011
Location: Halifax - Canada
Posts: 266
Likes: 0
Received 5 Likes on 1 Post
Originally Posted by rotadent View Post
Hi All,

First I want to say thanks for uploading everything and writing up the instruction manual, GTECKO.

I'm having some issues with the car after I installed some of the ECU changes. I installed the one touch sunroof and that seems to be working fine now. It wasn't for the first few times, but now it seems OK. I also installed the always show digital speed change and that went without a hitch.

I am having problems with the close windows with fob. When I open the windows and sunroof, the sunroof only tilts. Isn't it supposed to open all the way? It does close completely though.

Also, what bugs me most, is every time I shut the car down, there is a really annoying "grinding-clicking" sound that lasts for about 3 seconds. I think it's the same type of sound that you get when you are programming the ECU. But I'm not programming it now! I don't have the usb cable or the laptop plugged in.

Anyone else have this problem or can shed some light on this? I'm running v38 datens.
You are very welcome!

You are saying you having a problem "with the close windows with fob", however you are mentioning having the tilt open sunroof not opening all the way ...
If you open the windows/sunroof with the comfort open from fob, your sunroof will only tilt.
I confirmed it with other members, it only tilt opens on the R56s.
If you sunroof is open all the way, it will close no problem from the fob.

As for that sound you are talking about, my car locks the doors and trunk at the same time(since I put auto door unlock in CAS module ER_KEYOUT_AUTOVR), therefore when I close it, it makes an odd noise, if you press twice, it will sounds like the noise you are refering to when coding CAS...
let us know
 
  #32  
Old 05-24-2011, 07:51 PM
rotadent
rotadent is offline
2nd Gear
Join Date: Apr 2009
Location: Irvine, CA
Posts: 68
Likes: 0
Received 0 Likes on 0 Posts
Ok. You're correct on the sunroof issue with the fob. Everything is standard there.

I'm going to try again tomorrow and look for the noise. It only happens when I turn the engine off. And it's not a door locking noise. It sounds like someone sticking a pencil in a fan while the fan is slowing down.

Updates tomorrow.
 
  #33  
Old 05-24-2011, 08:53 PM
robinj's Avatar
robinj
robinj is offline
3rd Gear
Join Date: Mar 2010
Location: Boston, South Shore
Posts: 260
Likes: 0
Received 0 Likes on 0 Posts
just out of curiosity, the USB cord mentions 1st gens as well.. any interesting tidbits/tweaks/etc for the R50-R53s from the 30GB of data?
 
  #34  
Old 05-25-2011, 10:57 AM
rotadent
rotadent is offline
2nd Gear
Join Date: Apr 2009
Location: Irvine, CA
Posts: 68
Likes: 0
Received 0 Likes on 0 Posts
Update...

After two instances of turning the ignition off, there are no more noises.

Let's hope this is the last issue.

Also, GTECKO, in you write up, to write the file to the ECU, you state that you may have a wait a while for it to program. It really only took the computer about 2 seconds. I was expecting minutes!
 
  #35  
Old 05-25-2011, 01:33 PM
GTECKO's Avatar
GTECKO
GTECKO is offline
3rd Gear
Thread Starter
Join Date: Feb 2011
Location: Halifax - Canada
Posts: 266
Likes: 0
Received 5 Likes on 1 Post
Originally Posted by rotadent View Post
Update...

After two instances of turning the ignition off, there are no more noises.

Let's hope this is the last issue.

Also, GTECKO, in you write up, to write the file to the ECU, you state that you may have a wait a while for it to program. It really only took the computer about 2 seconds. I was expecting minutes!
Glad to hear you got no more weird noises lol
Well you know, some modules take longer, like FRM and KOMBI takes longer than CAS ... or if you change ur vehicle order, that would take a minute

just out of curiosity, the USB cord mentions 1st gens as well.. any interesting tidbits/tweaks/etc for the R50-R53s from the 30GB of data?
Well unfortunatly this is a second generation based forum, so I only updated the files with R56 datens. if you get the proper datens, you can definitely do this with the R53.
Cheers
 
  #36  
Old 05-25-2011, 06:32 PM
CORNERS's Avatar
CORNERS
CORNERS is offline
3rd Gear
iTrader: (1)
Join Date: Sep 2010
Location: Seattle, WA
Posts: 246
Likes: 0
Received 0 Likes on 0 Posts
I might need some help. I am unable to download the files. I click through a warning about unable to scan for viruses, then nothing happens.
Thanks,
 
  #37  
Old 05-25-2011, 06:42 PM
rotadent
rotadent is offline
2nd Gear
Join Date: Apr 2009
Location: Irvine, CA
Posts: 68
Likes: 0
Received 0 Likes on 0 Posts
Bad news... the noises came back. I took a short drive for lunch and the noise came back when I arrived at the destination. It lasted about 2 seconds. When I went back to the office, it happened again, but only for 0.5 seconds. Very brief. Maybe this has to do with the engine being cold? It's a nice 75-80F outside, so I am baffled at this. I'm not sure this has to do with the ECU change.

Maybe the reason why it didn't happen this morning was that it took over 30 minutes to get to work.

More testing on the way...
 
  #38  
Old 05-25-2011, 08:17 PM
GTECKO's Avatar
GTECKO
GTECKO is offline
3rd Gear
Thread Starter
Join Date: Feb 2011
Location: Halifax - Canada
Posts: 266
Likes: 0
Received 5 Likes on 1 Post
ok so Iam not sure why you cant get it from google doc ... doesnt make sence
here is another link you have to wait 90 seconds before downloading, it would take 10 minutes to download.
Cheers
 
  #39  
Old 05-25-2011, 08:47 PM
CORNERS's Avatar
CORNERS
CORNERS is offline
3rd Gear
iTrader: (1)
Join Date: Sep 2010
Location: Seattle, WA
Posts: 246
Likes: 0
Received 0 Likes on 0 Posts
Thanks, it worked.
 
  #40  
Old 05-25-2011, 09:11 PM
CORNERS's Avatar
CORNERS
CORNERS is offline
3rd Gear
iTrader: (1)
Join Date: Sep 2010
Location: Seattle, WA
Posts: 246
Likes: 0
Received 0 Likes on 0 Posts
One question. Do you have V40 Daten for R50?
 
  #41  
Old 07-22-2011, 07:28 PM
TiggerGTO
TiggerGTO is offline
3rd Gear
Join Date: Jan 2011
Posts: 152
Likes: 0
Received 0 Likes on 0 Posts
I have spent the last couple evenings attempting to get NCS Expert to work. I downloaded the "Mini Cooper Coding" package and followed the directions. The cable and INPA seemed to work fine. Unfortunately, when I tried running ncsexper, I found out that it won't run in 64-bit Windows 7. I installed XP Mode on my Windows 7 and went through the install process a second time. When I ran LADEN.BAT, I noticed some errors, but I couldn't tell if it was normal. Looking at the batch code, it looks like some of the sections are trying to copy files to paths or drives that don't exist. I don't know if this is okay or not.

Next, I couldn't get ncsexper to read the modules. I kept getting various errors. One Error dialog said:
Following feature is invalid for FA: $7L7

Could this be related to the errors I saw when running LADEN.BAT? I tried with both v38 and v40 datens.

I uninstalled all of this, and installed the software from "350517-inpa k+can.rar" following the directions in the PDF embedded in there. I seem to have everything working now, except I get different behavior depending on which module I try to read. Sometimes a NETTODAT.TRC pops up in notepad. Sometimes I get a German dialog box that may or may not be an important error. I translated one of them using Google translate and it said "file is already opened". I'm not sure what I did. Maybe I got confused and still had FSW_PSW.TRC opened in notepad between module reads. What happens if you read a second module into a non-empty FSW_PSW.TRC file? Do they get combined? Does it overwrite the first one?

Based on looking at the spread sheet, I attempted to read CAS, FRM (couldn't find FRM2), SHD and HAMP (couldn't find CHAMP). Before I start changing values and writing them back to the car, it would be great if I could verify that the files are complete and correct. Until I know I have good trace files to start with, I don't want to do anything with them.

I assume you have to write the whole trace file even if you are only changing one, two or a few values. What happens if you only include the small number of values you want to change? Will it leave the rest alone? Does anybody have samples of the unmodified trace file for these modules? I'd love to compare what I read from my car with another person's files. In case it matters, the files I have are using the v40 datens and I read them from my 2011 JCW Hardtop.

Thanks
 

Last edited by TiggerGTO; 07-22-2011 at 07:50 PM.
  #42  
Old 07-30-2011, 10:52 AM
Juppers
Juppers is offline
2nd Gear
Join Date: Jun 2011
Posts: 104
Likes: 0
Received 0 Likes on 0 Posts
Where do you find the list of options for changing your VO? I plan on adding rear fogs and factory alarm in the near future, and am just trying to plan ahead. Perhaps that could be added to the google docs spreadsheet.
 
  #43  
Old 08-14-2011, 02:07 PM
Sacred Disorder
Sacred Disorder is offline
3rd Gear
Join Date: Dec 2010
Location: Petersburg, Michigan
Posts: 298
Likes: 0
Received 0 Likes on 0 Posts
Can you connect Via a KIWI WiFi device? Also could you potentially get in and turn off the Automatic down shift for an automatic car?
 
  #44  
Old 08-14-2011, 04:23 PM
threar
threar is offline
4th Gear
Join Date: Jul 2010
Location: Boulder, CO
Posts: 379
Likes: 0
Received 1 Like on 1 Post
Originally Posted by Sacred Disorder View Post
Can you connect Via a KIWI WiFi device? Also could you potentially get in and turn off the Automatic down shift for an automatic car?
Yes you can connect via a KIWI WiFI. I do it quite regularly to gather data from my MINI.
 
  #45  
Old 08-14-2011, 06:14 PM
GTECKO's Avatar
GTECKO
GTECKO is offline
3rd Gear
Thread Starter
Join Date: Feb 2011
Location: Halifax - Canada
Posts: 266
Likes: 0
Received 5 Likes on 1 Post
Where do you find the list of options for changing your VO? I plan on adding rear fogs and factory alarm in the near future, and am just trying to plan ahead. Perhaps that could be added to the google docs spreadsheet.
There is actually a pdf document for changing the VO, have you ever gone to the bimmer website ?
I can't really add the steps on the google docs as it is a different manipulation then changing the modules. Try to go on the bimmer website, there s one there,very easy to follow
 
  #46  
Old 08-15-2011, 04:35 PM
Juppers
Juppers is offline
2nd Gear
Join Date: Jun 2011
Posts: 104
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by GTECKO View Post
There is actually a pdf document for changing the VO, have you ever gone to the bimmer website ?
I can't really add the steps on the google docs as it is a different manipulation then changing the modules. Try to go on the bimmer website, there s one there,very easy to follow
Not the steps on how to do it, but the option codes themselves.

Been there, can't find squat on that site. Haven't found that pdf yet, haven't found much of anything useful there yet.
 
  #47  
Old 08-16-2011, 04:16 AM
TiggerGTO
TiggerGTO is offline
3rd Gear
Join Date: Jan 2011
Posts: 152
Likes: 0
Received 0 Likes on 0 Posts
I don't have the link to the post on the Bimmer site, but I did save the link to the document that it referenced.
 
  #48  
Old 09-02-2011, 07:58 AM
GTECKO's Avatar
GTECKO
GTECKO is offline
3rd Gear
Thread Starter
Join Date: Feb 2011
Location: Halifax - Canada
Posts: 266
Likes: 0
Received 5 Likes on 1 Post
Originally Posted by Juppers View Post
Not the steps on how to do it, but the option codes themselves.

Been there, can't find squat on that site. Haven't found that pdf yet, haven't found much of anything useful there yet.
Here are the pdf you wanted
using ncs to change VO.pdf

NCS changing vehicule order CAS.pdf
 
  #49  
Old 09-02-2011, 08:17 AM
Juppers
Juppers is offline
2nd Gear
Join Date: Jun 2011
Posts: 104
Likes: 0
Received 0 Likes on 0 Posts
Thanks. Here is the information I was looking for though, but the process is good to know as well. I found the option code list at http://www.bimmerfest.com/forums/showthread.php?t=98757
 
  #50  
Old 09-05-2011, 09:15 AM
SpyVsSpy
SpyVsSpy is offline
2nd Gear
Join Date: Mar 2009
Location: Washington
Posts: 98
Likes: 0
Received 0 Likes on 0 Posts
I downloaded file 350517-inpa k+can.rar (563MB) and purchased the cable. I nstalled it on my XP laptop and when I went to select R56 (F3) I received error "Couldn't find INPA configuration file C:\EC-APPS\INPA\BIN\...|cfgdat\E53.ENG" I think the download did not include the Daten for any vehicle? How can I tell? Or where can I get them for my 2007 R56?
 

Thread Tools
Search this Thread
Quick Reply: NCSExpert for beginners


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: