F55/F56 :: Hatch Talk (2014+) MINI Cooper and Cooper S (F55/F56) hatchback discussions.
Sponsored by:
Sponsored by:

F55/F56 Dinan Double Dilemma

  #1  
Old 04-12-2019, 12:48 PM
MikeMJCW
MikeMJCW is offline
3rd Gear
Thread Starter
Join Date: Jun 2018
Posts: 165
Received 25 Likes on 20 Posts
Dinan Double Dilemma

So I got my car back (check eng light)…. Dealer said something about Waste gate/intake manifold pressure to high on coastdown (?? give me a Holley 4 barrel). This will be the 3rd Dinan Elite installed on my car. The 1st unit was the wrong one (dealer fault) the 2nd was the issue just mentioned. When I originally test rode the car I was fine with the stock HP but I wasn't going to leave the dealer without a Dinan. So this whole time I was driving with bad modules, hope these bad modules didn't cause any issues, Dinan said it shouldn't of course. Well now on this 3rd unit... and WTF.... the car accelerates and looses traction like crazy. Are these car's this fast..? it's F#$#%# crazy.. I love it, it's like I have an out of control Mini Monster.
 

Last edited by MikeMJCW; 07-15-2019 at 02:08 PM.
The following 2 users liked this post by MikeMJCW:
bratling (04-14-2019), drhow (04-14-2019)
  #2  
Old 04-12-2019, 01:21 PM
tc1728
tc1728 is offline
2nd Gear
Join Date: Mar 2019
Posts: 115
Received 23 Likes on 19 Posts
I have put off installing my Elite for about 6 months now because of the CEL issues I have been seeing so it's nice to hear some "success" stories once in a while. I'm most likely gonna have mine done later this month.
 
The following users liked this post:
MikeMJCW (04-13-2019)
  #3  
Old 04-12-2019, 01:24 PM
RLM
RLM is offline
2nd Gear
Join Date: Jan 2014
Posts: 103
Likes: 0
Received 19 Likes on 18 Posts
I dont have the DINAN, but have the racechip, Short answer is yes, these cars go like a bat out of hell with a good plug in like the elite or racechip. the DINAN sport however only gave a modest jump that was only really noticeable in the low rev range.
 
The following users liked this post:
MikeMJCW (04-13-2019)
  #4  
Old 04-13-2019, 03:14 PM
El-Grunto's Avatar
El-Grunto
El-Grunto is online now
2nd Gear
Join Date: Jan 2019
Location: Seattle, WA
Posts: 136
Received 33 Likes on 25 Posts
I just had the 2nd Dinan Elite taken off my car on the 10th due to CELs. In short, yes the cars does go fast with a Dinan and with a set of warmed up sticky 205/45/17R MPSS' you can still break traction easily while shifting 1st to 2nd. But the CELs were too much for me. Dinan is supposed to be bulletproof and give no issues yet my experience was the opposite. Even with the bypass installed I was still getting CELs. This leads me to believe it was possibly an issue with the wiring harness. But like I said, it came off Wednesday and I returned it for the 2nd time but also for a refund rather than a replacement. I've driven 300-400 miles in the few days since having the Dinan removed and haven't had a CEL come back yet.
 
  #5  
Old 04-13-2019, 05:46 PM
pillpusher84
pillpusher84 is offline
1st Gear
Join Date: Sep 2018
Posts: 35
Likes: 0
Received 5 Likes on 4 Posts
I have a pre-December 2014 Dinan Elite on my 2015 F55, and it has been great since install ~4 months ago. I bought this car used in September 2018 with 14k on the clock, and still under manufacturer's warranty. I have put about 1,000 miles on the car to-date with the Dinan, and it's awesome. I have also paired it with a Sprint Booster Pedal Tuner and I have it dialed in just right now. I have also installed the Dinan cat-back exhaust.
 
  #6  
Old 04-13-2019, 10:11 PM
El-Grunto's Avatar
El-Grunto
El-Grunto is online now
2nd Gear
Join Date: Jan 2019
Location: Seattle, WA
Posts: 136
Received 33 Likes on 25 Posts
Originally Posted by pillpusher84 View Post
I have a pre-December 2014 Dinan Elite on my 2015 F55, and it has been great since install ~4 months ago. I bought this car used in September 2018 with 14k on the clock, and still under manufacturer's warranty. I have put about 1,000 miles on the car to-date with the Dinan, and it's awesome. I have also paired it with a Sprint Booster Pedal Tuner and I have it dialed in just right now. I have also installed the Dinan cat-back exhaust.
Mine was a similar situation. 2015 F56 S with Sprint Booster v3, Remus Sport exhaust, & midpipe resonator delete. The Dinan Elite went on around 30K miles. Was great for about 2.5K miles then I started getting issues. Troubleshooted them with Dinan over the course of 5 weeks and they couldn't fix the problems. So the Elite went back, I got a refund, and the issues haven't come back since then. Glad yours has worked flawlessly and I hope it stays that way.
 
  #7  
Old 06-25-2019, 05:29 AM
MikeMJCW
MikeMJCW is offline
3rd Gear
Thread Starter
Join Date: Jun 2018
Posts: 165
Received 25 Likes on 20 Posts
So the check engine light is back on. This time going straight to the Peabody dealership as this is becoming routine (Warwick wont touch it). 4 trips in 6k miles. If this turns out to be another faulty Dinan module I plan on suing for a full refund of the module. I bought "factory" for reliability. BTW I got so pissed I put a feeler on the for sale site :(
My next question is what module/tune out there actually works i.e. NM etc.?
 
  #8  
Old 06-25-2019, 06:49 AM
RLM
RLM is offline
2nd Gear
Join Date: Jan 2014
Posts: 103
Likes: 0
Received 19 Likes on 18 Posts
i've had no problems at all with my Racechip GTS. been running it since march, probably about 5000KM with no issues. I currently have a CEL for O2 sensor reading but that only started after I did a downpipe lol.
 
The following users liked this post:
MikeMJCW (06-26-2019)
  #9  
Old 06-25-2019, 09:39 AM
El-Grunto's Avatar
El-Grunto
El-Grunto is online now
2nd Gear
Join Date: Jan 2019
Location: Seattle, WA
Posts: 136
Received 33 Likes on 25 Posts
Dude that sucks. NM and the JB4 seem to be the preferred modules nowadays. After having issues with the Elite for months I returned it for a refund and went RPM Stage 2 and haven't looked back. I was planning on doing an ECU flash eventually anyway so the Dinan problems just accelerated my plans.
 
The following users liked this post:
MikeMJCW (06-26-2019)
  #10  
Old 06-25-2019, 09:45 AM
USA-RET's Avatar
USA-RET
USA-RET is offline
6th Gear
Join Date: Apr 2015
Location: Bonita Springs Florida
Posts: 1,149
Received 90 Likes on 74 Posts
BMW M240i Elites had similar issues. Mine still does, but have mitigated it somewhat by running it with the shift lever in the M/S position all the time. Higher RPM's seem to eliminate the CEL's. Dinan intro'ed a .v2 of the original Elite (the original was pulled off the market). The new .v2 is essentially the "Dinan sport" w/ the piggyback warranty of the original .v1 Elite. Those that went with the trade out don't have CEL's they had w/ the .v1, but find that the there is a performance drop between the .v1 and .v2. Not nearly as explosive as the .v1 Most are reasonably happy since we are waiting for the Stage 2 flash anyway.
 
The following users liked this post:
MikeMJCW (06-26-2019)
  #11  
Old 06-25-2019, 11:16 AM
Minnie.the.Moocher's Avatar
Minnie.the.Moocher
Minnie.the.Moocher is offline
6th Gear
Join Date: Jun 2014
Location: earth PNW
Posts: 4,740
Received 404 Likes on 352 Posts
Originally Posted by MikeMJCW View Post
So the check engine light is back on. This time going straight to the Peabody dealership as this is becoming routine (Warwick wont touch it). 4 trips in 6k miles. If this turns out to be another faulty Dinan module I plan on suing for a full refund of the module. I bought "factory" for reliability. BTW I got so pissed I put a feeler on the for sale site :(
My next question is what module/tune out there actually works i.e. NM etc.?
Who did you buy it from? Unit has a two year warranty. Who you going to sue? And how? That really isn't anything but frustration talking. Be calm and contact reseller and or Dinan direct and tell them what you expect.

btw - if it happened with mine I'd just go get an ECU tune.
 
The following users liked this post:
MikeMJCW (06-26-2019)
  #12  
Old 06-26-2019, 03:36 AM
MikeMJCW
MikeMJCW is offline
3rd Gear
Thread Starter
Join Date: Jun 2018
Posts: 165
Received 25 Likes on 20 Posts
Hey mooch, your D#AMN right I'm frustrated. This module is unreliable. Car will be at dealership 2-3 days. Mechanics are probably taking turns getting 1G on the exit ramps. :-(
Info: Purchased module from dealer, MINI of Peabody ($1000 installed). I decided to give the 3rd unit a try, if it fails I'm asking for a refund of the module. If they they don't refund me then I'm seeking legal help. Doesn't seem unreasonable to me.
So my options are NM, JB4. Racechip GTS & ECU tune re-maps like these guys do https://brentuning.com/product/mini-...uning-deposit/
 
  #13  
Old 06-26-2019, 05:55 AM
f60jcw's Avatar
f60jcw
f60jcw is offline
4th Gear
Join Date: May 2017
Posts: 379
Received 62 Likes on 50 Posts
Watching this thread. Just got mine a few weeks ago. I'm loving it but hope to not run into issues.
 
  #14  
Old 06-26-2019, 08:34 AM
USA-RET's Avatar
USA-RET
USA-RET is offline
6th Gear
Join Date: Apr 2015
Location: Bonita Springs Florida
Posts: 1,149
Received 90 Likes on 74 Posts
Originally Posted by MikeMJCW View Post
Hey mooch, your D#AMN right I'm frustrated. This module is unreliable. Car will be at dealership 2-3 days. Mechanics are probably taking turns getting 1G on the exit ramps. :-(
Info: Purchased module from dealer, MINI of Peabody ($1000 installed). I decided to give the 3rd unit a try, if it fails I'm asking for a refund of the module. If they they don't refund me then I'm seeking legal help. Doesn't seem unreasonable to me.
So my options are NM, JB4. Racechip GTS & ECU tune re-maps like these guys do https://brentuning.com/product/mini-...uning-deposit/
Dinan has been pretty good about doing refunds on components that don't perform as expected. Just go back though the dealer that bought and installed it, as Dinan will want their input on what was done throughout the process.

A shame too. Dinan has had a sterling reputation with their tunes in the past. Seems like their latest modules with the newer BMW engines has not been good.
 
The following users liked this post:
MikeMJCW (06-26-2019)
  #15  
Old 06-26-2019, 09:02 AM
MikeMJCW
MikeMJCW is offline
3rd Gear
Thread Starter
Join Date: Jun 2018
Posts: 165
Received 25 Likes on 20 Posts
That's good (and bad) to hear. I'll give it one more try, I might even dyno (Bren tuning) it to see if their claims are true. If I go with a race chip GTS then I can unplug it and have the non Dinan dealer service to car. No more 3 hour trips to go 65mi thru Boston traffic.
 
  #16  
Old 06-26-2019, 10:36 AM
tc1728
tc1728 is offline
2nd Gear
Join Date: Mar 2019
Posts: 115
Received 23 Likes on 19 Posts
I have had issues as well with my Dinan Elite but ECS and Dinan have been awesome throughout all of my issues.
 
The following 2 users liked this post by tc1728:
ECSTuning (06-26-2019), MikeMJCW (06-26-2019)
  #17  
Old 06-27-2019, 10:41 AM
MikeMJCW
MikeMJCW is offline
3rd Gear
Thread Starter
Join Date: Jun 2018
Posts: 165
Received 25 Likes on 20 Posts
Just picked up the car, felt a bit slower than the 2nd module but it was hot here today 86 deg. We'll see how this module works out. Thanks everyone for your input.
 
  #18  
Old 06-27-2019, 03:18 PM
Darbys2019MiniJCW's Avatar
Darbys2019MiniJCW
Darbys2019MiniJCW is offline
2nd Gear
Join Date: Apr 2019
Location: New Braunfels, Texas
Posts: 96
Received 31 Likes on 20 Posts
I installed the NM Power Module and it worked immediately and power increase if obvious....
easy to put on and take off without a trace...
 
  #19  
Old 06-27-2019, 03:40 PM
rtowell's Avatar
rtowell
rtowell is offline
3rd Gear
Join Date: Apr 2016
Location: Merritt Island, FL
Posts: 234
Received 25 Likes on 19 Posts
I had issues with the first unit so I plugged in the bypass plug and the CEL cleared. They were very responsive and the second unit works great. Good solid mid-range ... much better pull and very, very smooth. Pretty happy now.
 
The following 2 users liked this post by rtowell:
ECSTuning (07-02-2019), MikeMJCW (06-29-2019)
  #20  
Old 07-05-2019, 01:14 PM
MikeMJCW
MikeMJCW is offline
3rd Gear
Thread Starter
Join Date: Jun 2018
Posts: 165
Received 25 Likes on 20 Posts
So I gave the 3rd module a week, put it thru the normal paces, barely notice an increase in HP. The car is much smoother without the module, if anyone else has noticed that?
The 2nd module was definitely faster. Contacted dealer asked for a refund and now have to wait for sales manager to come in next week.
I'll be shocked if dealer doesn't fight this.
 
  #21  
Old 07-05-2019, 02:16 PM
rtowell's Avatar
rtowell
rtowell is offline
3rd Gear
Join Date: Apr 2016
Location: Merritt Island, FL
Posts: 234
Received 25 Likes on 19 Posts
So I gave the 3rd module a week, put it thru the normal paces, barely notice an increase in HP. The car is much smoother without the module, if anyone else has noticed that?
The 2nd module was definitely faster. Contacted dealer asked for a refund and now have to wait for sales manager to come in next week.
I'll be shocked if dealer doesn't fight this.
That's really strange. I definitely notice an increase, especially in the mid-range. The increase is subtle, but noticeable. It didn't turn into a fire-breathing monster, but I definitely appreciate the difference. As for smoothness, my experience has been the opposite ... my impression is that the car is much smoother, possibly because it requires much less throttle in normal driving. Also, it pull very strong up to redline now.
 
The following users liked this post:
MikeMJCW (07-05-2019)
  #22  
Old 07-05-2019, 02:25 PM
cmt52663
cmt52663 is offline
6th Gear
Join Date: Jun 2006
Posts: 3,453
Received 61 Likes on 48 Posts
Here's a Bren Tuning dyno chart for my JCW with the Dinan Elite. Mini of Peabody did the install. The Dinan was installed at 26k miles, and was replaced at no charge at 42.9k due to a couple of codes that went away when the bypass plug was reinstated. MoP has always treated me well, and I have particular confidence in Joel DeCoff, their chief mechanic, who has acted as unofficial crew chief on all four of my cars over the years.

Cheers,

Charlie

 
The following users liked this post:
MikeMJCW (07-05-2019)
  #23  
Old 07-05-2019, 03:54 PM
MikeMJCW
MikeMJCW is offline
3rd Gear
Thread Starter
Join Date: Jun 2018
Posts: 165
Received 25 Likes on 20 Posts
The 3rd module did turn it into a little beast (see my old post), the other ones didn't however, for all I know they could be damaging something. I'm hoping MINI of Peabody just refunds me, I'm not unreasonable it's been 4 modules.
 

Last edited by MikeMJCW; 07-15-2019 at 02:10 PM.
  #24  
Old 07-05-2019, 04:06 PM
pillpusher84
pillpusher84 is offline
1st Gear
Join Date: Sep 2018
Posts: 35
Likes: 0
Received 5 Likes on 4 Posts
Originally Posted by pillpusher84 View Post
I have a pre-December 2014 Dinan Elite on my 2015 F55, and it has been great since install ~4 months ago. I bought this car used in September 2018 with 14k on the clock, and still under manufacturer's warranty. I have put about 1,000 miles on the car to-date with the Dinan, and it's awesome. I have also paired it with a Sprint Booster Pedal Tuner and I have it dialed in just right now. I have also installed the Dinan cat-back exhaust.
So... looks like I got bit with the CEL bug too. Just approximately 2k on the odometer since DINAN Elite installed. I had a CEL come on, and cleared it. About 80 miles additional on her and the CEL is back.

ISTA/D shows code 1B8302 - LIN, Communication (environmental air catalyst sensor):Missing

i have double checked that my connectors for the wiring have not come loose and confirmed that no water has gotten into the connectors.

What was the code everyone else has been getting with your DINAN units?

I keep my mini in the garage 100% of the time and only drive when the weather is nice. Very hard to imagine that any outside factor has contributed to an issue here. My guess is I’m experiencing what everyone else has been complaining about for a while.

FWIW, I have a November 2014 build F55 Cooper S.
 
The following users liked this post:
MikeMJCW (07-06-2019)
  #25  
Old 07-05-2019, 04:16 PM
Minnie.the.Moocher's Avatar
Minnie.the.Moocher
Minnie.the.Moocher is offline
6th Gear
Join Date: Jun 2014
Location: earth PNW
Posts: 4,740
Received 404 Likes on 352 Posts
"ISTA/D shows code 1B8302 - LIN, Communication (environmental air catalyst sensor):Missing"

Check post #32 https://www.northamericanmotoring.co...ml#post4305844
 
The following users liked this post:
MikeMJCW (07-06-2019)

Thread Tools
Search this Thread
Quick Reply: F55/F56 Dinan Double Dilemma


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.