Electrical For discussions regarding wiring up electrical modifications such as radar detectors, brake light mods, power sockets, and driving lights in Clubman (R55), Cooper and Cooper S (R56), and Cabrio (R57) MINIs.

NCSExpert DIY(do it yourself)

  #26  
Old 04-04-2011, 10:10 AM
GeoffreyM
GeoffreyM is offline
4th Gear
Join Date: Dec 2010
Location: NOLA
Posts: 502
Likes: 0
Received 0 Likes on 0 Posts
I am on V40 datens, and I can't read the FRM module. I keep getting a Best Version error. Any ideas? I have had success with all of the others, but no dice on FRM or the new MEDIA module.
 
  #27  
Old 04-04-2011, 02:34 PM
strobeyprobey
strobeyprobey is offline
6th Gear
Join Date: Apr 2008
Location: Twin Cities, Minnesota
Posts: 1,303
Likes: 0
Received 3 Likes on 3 Posts
I had a similar issue when I upgraded to v40. I ended up having to replace just my FRM specific files with v34 to access the FRM module again.
 
  #28  
Old 04-04-2011, 03:45 PM
GeoffreyM
GeoffreyM is offline
4th Gear
Join Date: Dec 2010
Location: NOLA
Posts: 502
Likes: 0
Received 0 Likes on 0 Posts
Hmmmm. Don't suppose you'd be willing to elaborate? Are v34 datens the ones that come with the original download of the software?
 
  #29  
Old 04-04-2011, 06:22 PM
BBoshart
BBoshart is offline
3rd Gear
Join Date: Jun 2008
Location: Seattle
Posts: 157
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by GeoffreyM View Post
Hmmmm. Don't suppose you'd be willing to elaborate? Are v34 datens the ones that come with the original download of the software?
You can get the v34 from bimmerforums. http://forums.bimmerforums.com/forum...36&postcount=8. Just temporarily replace your v40 to read the FRM. Not positive it'll work with your R60 though but it's worth a try.
 
  #30  
Old 04-05-2011, 03:01 PM
GeoffreyM
GeoffreyM is offline
4th Gear
Join Date: Dec 2010
Location: NOLA
Posts: 502
Likes: 0
Received 0 Likes on 0 Posts
I tried, the 2011 computers don't like the old datens. Strobey did you have trouble with the V39 datens too? I may try that tomorrow. Still looking for v41, supposedly they've been sent to dealers. Just have to find an unscrupulous or pissed off tech to steal them!!
 
  #31  
Old 04-06-2011, 01:36 PM
GTECKO's Avatar
GTECKO
GTECKO is offline
3rd Gear
Thread Starter
Join Date: Feb 2011
Location: Halifax - Canada
Posts: 266
Likes: 0
Received 5 Likes on 1 Post
Iam having a lot of difficulties to get the V40 ...get all the .rar but tell me some are corrupted ...3rd time Iam downloading them ...3rd time the charm

Can someone show me how to change the VO so that my car is like an european one ? I have now the DRL function as others may have however Iam still wanting to have this auto light on working ... when its sunny out, I dont want my headlights on ... anyone ??
 
  #32  
Old 04-13-2011, 03:34 PM
oonemesisoo's Avatar
oonemesisoo
oonemesisoo is offline
2nd Gear
Join Date: Feb 2011
Location: Long Island
Posts: 56
Likes: 0
Received 1 Like on 1 Post
Successfully coded my CM. marked off the spreadsheet 2011 approved for everything under FRM2. Comfort closing is awesome! Didn't attempt the nav disclaimer but i believe i read it wont work until v41 datens are out? I changed the setting for drl but now they don't turn on at all. I was looking for the smaller light above the fog to turn on but leave my headlights off. any suggestions?
 
  #33  
Old 04-17-2011, 09:17 PM
gjn25
gjn25 is offline
3rd Gear
Join Date: Aug 2009
Location: Miami, FL / Palm Beach, FL
Posts: 165
Likes: 0
Received 0 Likes on 0 Posts
dose anyone live in south FL and would have a lill time to help me learn how to do all of this coding. I would like to do some small stuff like one touch sunroof but I'm not 100% sure I can do it with out killing me car on my own! please if anyone can help PM me thanks
 
  #34  
Old 04-22-2011, 03:10 PM
jman311
jman311 is offline
2nd Gear
iTrader: (1)
Join Date: Oct 2009
Location: Arizona
Posts: 79
Likes: 0
Received 0 Likes on 0 Posts
I gave this a go today and have successfully coded settings in several modules. I too am unable to read the FRM module, also getting the Best Version error (I'm on V38 Datens). Do I need to use the V34 Datens for this to work?

The only setting that I changed that's not actually working is the one for auto-unlocking the doors in the CAS module (ER_KEYOUT_AUTOVR, set to aktiv). I was able to program it, it just doesn't seem to work. Doors don't unlock on killing the engine nor removing the fob.

Connected to a '10 MCS w/ comfort access.

EDIT: Turns out the auto-unlocking feature does work, but only if the auto-lock feature is turned on in the car settings menu. Apparently if this menu item is not enabled and the doors are locked manually, they don't unlock with ignition kill/keyfob removal.
 

Last edited by jman311; 04-22-2011 at 04:28 PM.
  #35  
Old 04-27-2011, 12:09 PM
GTECKO's Avatar
GTECKO
GTECKO is offline
3rd Gear
Thread Starter
Join Date: Feb 2011
Location: Halifax - Canada
Posts: 266
Likes: 0
Received 5 Likes on 1 Post
Hey guys, new discovery by Chernobyl about having the alarm light blink without having an actual factory alarm in. Confirmed on my MCS 09 that it worked; updated the spreadsheet with it.
Theres a trick to actually read SPEG (if you get an error),either pm me or Chernobyl.
Cheers

check this page for reference

and my video
 
  #36  
Old 04-27-2011, 12:14 PM
jman311
jman311 is offline
2nd Gear
iTrader: (1)
Join Date: Oct 2009
Location: Arizona
Posts: 79
Likes: 0
Received 0 Likes on 0 Posts
Nice find! Hopefully we will get more discoveries like this rolling in ... I don't speak any German so deciphering the trace file descriptions is pretty much impossible. I found a list of translations over on bimmerforums but it wasn't too complete/helpful.

I am probably dreaming here but I'd like to figure out if it's possible to change the default display on the stereo (show track information). It's my biggest pet peeve having to change it every time I start the car.
 
  #37  
Old 04-27-2011, 08:57 PM
mamut
mamut is offline
3rd Gear
Join Date: Mar 2009
Location: Clifton, nj
Posts: 273
Likes: 0
Received 0 Likes on 0 Posts
Any idea if its possible to have the fogs stay on while flashing?
 
  #38  
Old 04-28-2011, 03:56 PM
GTECKO's Avatar
GTECKO
GTECKO is offline
3rd Gear
Thread Starter
Join Date: Feb 2011
Location: Halifax - Canada
Posts: 266
Likes: 0
Received 5 Likes on 1 Post
About two days ago I was exchanging some emails with Chernobyl and thanks to him I was able to make this work !!

If you guys see my previous msg #22 in another thread - I had an error.

So Chernobyl's idea is using the V32 files in the c:\ediabas\ecu folder and V38 (for me) for everything else.

worked like a charm, check out the video

 
  #39  
Old 05-01-2011, 12:19 PM
threar
threar is offline
4th Gear
Join Date: Jul 2010
Location: Boulder, CO
Posts: 379
Likes: 0
Received 1 Like on 1 Post
So, finally got a chance to try this out on my R60. Using the v40 Datens I was able to modify the CAS and SHD. I have a copy of the v41 Datens (found they were posted yesterday), but haven't had a chance to put them through their paces yet. So far, I've been able to backup the findings on the spreadsheet for R60 and v40.

As mentioned by others, the FRM module is giving me a BEST error (and v38 didn't work at all).
 
  #40  
Old 05-05-2011, 07:33 AM
jbourne
jbourne is offline
3rd Gear
Join Date: Jun 2010
Posts: 226
Likes: 0
Received 0 Likes on 0 Posts
GTECKO - thanks for keeping the spreadsheet up to date
 
  #41  
Old 05-05-2011, 03:08 PM
GTECKO's Avatar
GTECKO
GTECKO is offline
3rd Gear
Thread Starter
Join Date: Feb 2011
Location: Halifax - Canada
Posts: 266
Likes: 0
Received 5 Likes on 1 Post
Originally Posted by jbourne View Post
GTECKO - thanks for keeping the spreadsheet up to date
No problem, Im the "owner" now hahaha
 
  #42  
Old 05-05-2011, 04:41 PM
jbourne
jbourne is offline
3rd Gear
Join Date: Jun 2010
Posts: 226
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by GTECKO View Post
No problem, Im the "owner" now hahaha
i know rofl, cause i'm an idiot and didn't realise that you can't have >1 owner. anyway, it's cool - you're better placed to run it anyhow. carry on! hehe
 
  #43  
Old 05-06-2011, 06:03 PM
cmcveay
cmcveay is offline
3rd Gear
iTrader: (2)
Join Date: Jul 2009
Location: Annandale, VA
Posts: 265
Likes: 0
Received 0 Likes on 0 Posts
I've got the "heartbeat" working (09 R56) and I found that if I single click the lock, it has a rapid pulse for a short period of time but if I give it a double tap (brief pause between), it goes directly to the "heartbeat" mode.

Anyone take a look in the EPS module and see this?
TRQ_STEER_COMP
nicht_aktiv

I know the obvious for what it means but has anyone changed the setting to see what it does?
 
  #44  
Old 05-06-2011, 06:06 PM
jbourne
jbourne is offline
3rd Gear
Join Date: Jun 2010
Posts: 226
Likes: 0
Received 0 Likes on 0 Posts
Sorry - but what is this heartbeat?
 
  #45  
Old 05-06-2011, 06:41 PM
cmcveay
cmcveay is offline
3rd Gear
iTrader: (2)
Join Date: Jul 2009
Location: Annandale, VA
Posts: 265
Likes: 0
Received 0 Likes on 0 Posts
The red light in the tach that's tied to the OEM alarm. When activated and the car is locked, the light pulses with a slow "heartbeat".
 
  #46  
Old 05-08-2011, 11:55 AM
GTECKO's Avatar
GTECKO
GTECKO is offline
3rd Gear
Thread Starter
Join Date: Feb 2011
Location: Halifax - Canada
Posts: 266
Likes: 0
Received 5 Likes on 1 Post
Im pretty sure mine does the same thing.
You should try and let us know
 
  #47  
Old 05-08-2011, 06:36 PM
jasoncolorado's Avatar
jasoncolorado
jasoncolorado is offline
3rd Gear
iTrader: (2)
Join Date: Jul 2008
Location: Colorado
Posts: 198
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by peeti View Post
Anyone with R57 doing this? I am trying to figure out if the top down can be "one click" like the sunroof and would LOVE to, I mean LOVE LOVE to, program auto up on my windows. If you have suggestions, holler up please!
+1

Peeti...did you find out anymore info on this?
 
  #48  
Old 05-08-2011, 06:37 PM
jasoncolorado's Avatar
jasoncolorado
jasoncolorado is offline
3rd Gear
iTrader: (2)
Join Date: Jul 2008
Location: Colorado
Posts: 198
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by cmcveay View Post
I've got the "heartbeat" working (09 R56) and I found that if I single click the lock, it has a rapid pulse for a short period of time but if I give it a double tap (brief pause between), it goes directly to the "heartbeat" mode.

Anyone take a look in the EPS module and see this?
TRQ_STEER_COMP
nicht_aktiv

I know the obvious for what it means but has anyone changed the setting to see what it does?
Aww...the torque steer update. Would curious to know if that works.
 
  #49  
Old 05-09-2011, 09:49 AM
peeti's Avatar
peeti
peeti is offline
3rd Gear
Join Date: Dec 2010
Location: Chicagoland
Posts: 176
Likes: 0
Received 0 Likes on 0 Posts
Hei Jason - sorry no, just posted in the other thread looking for more. I'd even gladly grab one of those top modules, but for $400, I'm inclined to hold the button at the moment.

As for the torque steer - someone please try it. I went back and forth with my dealer and never got anywhere. I won't be in a position to try anything laptop related for at least two weeks, but dang if that works - I'll find a way!

P
 
  #50  
Old 05-11-2011, 11:57 AM
MyMiniS
MyMiniS is offline
1st Gear
Join Date: Apr 2009
Location: Long Island, NY
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by GTECKO View Post
Here is the spreadsheet , you need to request to view it (please do not edit randomly afterwards) and I will allow you view/edit it.
Requested.

Thank you.
 

Thread Tools
Search this Thread
Quick Reply: NCSExpert DIY(do it yourself)


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: