Dinan Elite JCW CEL P12A9 :(

  #1  
Old 12-22-2017, 09:35 AM
phantasms's Avatar
phantasms
phantasms is offline
5th Gear
Thread Starter
Join Date: Oct 2007
Location: Bedford, NY
Posts: 719
Received 13 Likes on 11 Posts
Dinan Elite JCW CEL P12A9 :(

edit: All is working well. Thank you Way and DINAN.
Hey guys,

My 2017 JCW has about 4k miles on it. I've had the Dinan Elite on for about 400 miles that I picked up from Way. I have felt it may have lost some of the initial grunt but it could be that I'm simply getting more used to it. Anyway I've been happy with the performance although I was expecting to have more tire spinning ability. Yesterday I was out for a long drive and hadn't been driving hard when I noticed a check engine light. I scanned it and it's the P12A9 code that means essentially it's detecting high boost pressure. Well duh. However I certainly would have thought the Dinan unit would allow it to run higher boost pressures without getting a CEL. I filled out their contact form but it doesn't say submitted so who knows if they got it. I've gone through several iginition cycles and it's still there. My DashCmd app wasn't able to clear it but that could be an app issue. Anyone have any recommendations? It's the only mod on the car. I'm kinda bummed and thinking about returning it as having an issue with it so soon makes me think there will be many more in the future.

Thoughts? Recommendations?

Thanks!

Best,
Gene




 

Last edited by phantasms; 03-27-2018 at 05:08 PM.
  #2  
Old 12-22-2017, 09:48 AM
Minnie.the.Moocher's Avatar
Minnie.the.Moocher
Minnie.the.Moocher is offline
6th Gear
Join Date: Jun 2014
Location: earth PNW
Posts: 4,654
Received 378 Likes on 331 Posts
I'd call Dinan.
I'd bypass the Elite at this point to see if code clears.
Others have had failed boost sensors without having tunes/piggybacks so it could be that.
 
  #3  
Old 12-22-2017, 02:55 PM
2017All4's Avatar
2017All4
2017All4 is offline
Moderator
Join Date: Aug 2016
Location: California Native still livin' in LaLa Land
Posts: 1,576
Received 193 Likes on 170 Posts
Codes should be evaluated by the dealer. If, after confirming everything with the car's systems appears okay and thus the dealer claims it's an issue with the Dinan box, then Dinan is pulled into the loop.

I am developing a theory that sometimes there are issues with the car lurking that get teased to the surface, but not necessarily caused by, the piggy-back.

Moocher is right that doing a bypass might clear the error -- but it won't tell you where the issue is.

Remember, Dinan claims we should fear no dealer if we go with the trusted Dinan name......

Buyer Beware.
 
  #4  
Old 12-22-2017, 06:08 PM
Mini_Vinnie's Avatar
Mini_Vinnie
Mini_Vinnie is offline
Moderator
iTrader: (1)
Join Date: Feb 2016
Location: Minneapolis, MN
Posts: 1,522
Received 221 Likes on 182 Posts
Clear the code and see if it happens again. Might be the box, or it could be a random spike that caused it
 
  #5  
Old 01-26-2018, 09:33 PM
boki
boki is offline
2nd Gear
Join Date: Jun 2014
Location: Bronx, NY
Posts: 79
Received 6 Likes on 6 Posts
OP, did you get this issue resolved? What was it?
 
  #6  
Old 02-01-2018, 08:48 AM
phantasms's Avatar
phantasms
phantasms is offline
5th Gear
Thread Starter
Join Date: Oct 2007
Location: Bedford, NY
Posts: 719
Received 13 Likes on 11 Posts
Still working on resolution. They finally reached out to me. I've been busy as of late. I tried the passthrough unit and it's still getting the CEL.
 
  #7  
Old 02-19-2018, 06:04 AM
boki
boki is offline
2nd Gear
Join Date: Jun 2014
Location: Bronx, NY
Posts: 79
Received 6 Likes on 6 Posts
So sorry to bother you but I'm thinking about getting the Dinan Elite for my 2016 Cooper S but not sure if I should. Did they figure it out what was causing the cel in your case?
 
  #8  
Old 03-19-2018, 08:06 PM
phantasms's Avatar
phantasms
phantasms is offline
5th Gear
Thread Starter
Join Date: Oct 2007
Location: Bedford, NY
Posts: 719
Received 13 Likes on 11 Posts
DINAN!!?!!??!

I STILL have the CEL and another one comes up every once in a while, P10F2, which cuts power.

I was working with Joe Phillips over there but he hasn't returned my emails in over a month. DINAN Please figure this out with me. I paid the pretty penny for the included warranty. I had zero issues before installing the unit and the car is 100% stock otherwise. These codes are related to high boost. Send me a different unit or different wiring harness for me to try. Talk to my local dealer and have them work with you guys to fix it. Better yet ask Way to take the unit back and you guys pay him for it. I've tuned tons of cars in a variety of ways and never had an issue like this before. Hell, I've purchased hundreds of mods from different manufacturers and never had to do the old forum ***** fest to get something accomplished.

Over it,
Gene


 
  #9  
Old 03-19-2018, 08:32 PM
Minnie.the.Moocher's Avatar
Minnie.the.Moocher
Minnie.the.Moocher is offline
6th Gear
Join Date: Jun 2014
Location: earth PNW
Posts: 4,654
Received 378 Likes on 331 Posts
Wow, I am shocked to hear how a company with a good reputation is screwing up on this.

Dinan
Way Motorworks
MINI

one of these companies needs to fix this for you. I'm guessing with it un-installed you won't see the issue, which lets MINI off the hook at that point.

I won't be buying anymore DINAN stuff if this is the way they treat you.
 
  #10  
Old 03-20-2018, 06:10 AM
Mini_Vinnie's Avatar
Mini_Vinnie
Mini_Vinnie is offline
Moderator
iTrader: (1)
Join Date: Feb 2016
Location: Minneapolis, MN
Posts: 1,522
Received 221 Likes on 182 Posts
Heck man, remember the old adage, the squeaky wheel gets the grease. Id call them every 2 hours until they get you a new unit.

Be annoying and inconvenient for them. By inconvenient I mean use social media to your advantage. They have a website, review section etc..
 
  #11  
Old 03-20-2018, 06:33 AM
boki
boki is offline
2nd Gear
Join Date: Jun 2014
Location: Bronx, NY
Posts: 79
Received 6 Likes on 6 Posts
Originally Posted by Minnie.the.Moocher View Post
Wow, I am shocked to hear how a company with a good reputation is screwing up on this.

Dinan
Way Motorworks
MINI

one of these companies needs to fix this for you. I'm guessing with it un-installed you won't see the issue, which lets MINI off the hook at that point.

I won't be buying anymore DINAN stuff if this is the way they treat you.
That's really disappointing, I can't believe that a company like Dinan can't resolve this for you, pretty embarrassing for them. I was thinking about getting Dinan Elite for my '16 Cooper S but I'm putting a hold on that till this is resolved for sure. Good luck OP and keep on calling them till they resolve this.
 
  #12  
Old 03-20-2018, 06:42 AM
Mini_Vinnie's Avatar
Mini_Vinnie
Mini_Vinnie is offline
Moderator
iTrader: (1)
Join Date: Feb 2016
Location: Minneapolis, MN
Posts: 1,522
Received 221 Likes on 182 Posts
Byte Tronik flash ..... just saying
 
  #13  
Old 03-20-2018, 06:53 AM
2017All4's Avatar
2017All4
2017All4 is offline
Moderator
Join Date: Aug 2016
Location: California Native still livin' in LaLa Land
Posts: 1,576
Received 193 Likes on 170 Posts
Has your MINI dealer checked out the codes?
 
  #14  
Old 03-20-2018, 07:12 AM
trentiles
trentiles is offline
4th Gear
Join Date: Apr 2014
Location: Buffalo, NY
Posts: 378
Received 35 Likes on 30 Posts
Originally Posted by Minnie.the.Moocher View Post
Wow, I am shocked to hear how a company with a good reputation is screwing up on this.

Dinan
Way Motorworks
MINI

one of these companies needs to fix this for you. I'm guessing with it un-installed you won't see the issue, which lets MINI off the hook at that point.

I won't be buying anymore DINAN stuff if this is the way they treat you.
Really makes you wonder how difficult a warranty claim would be with Dinan seeing they can't be bothered to help with a returning CEL while using their product. What a joke.

Sorry you are going through this OP
 
  #15  
Old 03-20-2018, 07:29 AM
Johras
Johras is offline
Neutral
Join Date: Nov 2016
Location: TN
Posts: 9
Likes: 0
Received 1 Like on 1 Post
Originally Posted by phantasms View Post
DINAN!!?!!??!

I STILL have the CEL and another one comes up every once in a while, P10F2, which cuts power.
These are the exact same codes I got with a Dinan Sport, started with just the P12A9 which didn't really affect anything. After a while I started to get the P10F2 code with reduced power.

Haven't had a single code since I removed it.
 
  #16  
Old 03-20-2018, 08:58 AM
TVPostSound
TVPostSound is offline
6th Gear
iTrader: (4)
Join Date: Mar 2014
Location: Granada Hills, CA
Posts: 1,539
Received 141 Likes on 129 Posts
At this point, you first need to remove the Dinan, including any harness of theirs.
Dont rely on the bypass plug, you want to remove the harness from the equation.

Then clear the codes. Dash Command did not clear my codes either. But a basic hand scanner at AutoZone did.

The lackadaisical responses from Dinan was the sole reason I sent my Elite back for a full refund.

Theres something not right about a piggyback solution.
 
  #17  
Old 03-20-2018, 09:22 AM
Mini_Vinnie's Avatar
Mini_Vinnie
Mini_Vinnie is offline
Moderator
iTrader: (1)
Join Date: Feb 2016
Location: Minneapolis, MN
Posts: 1,522
Received 221 Likes on 182 Posts
Originally Posted by TVPostSound View Post
Theres something not right about a piggyback solution.

I came to that point too and thats why I went the BT route. You are essentially tricking the ECU into doing something it isnt programmed to do with a piggyback.

I had the Sport and (knock on wood) didnt have any issues but just was a little leery of what was actually going on under the hood.

Its easy for me to spend others peoples money but for $100 more just get the BT full flash
 
  #18  
Old 03-20-2018, 09:33 AM
Minnie.the.Moocher's Avatar
Minnie.the.Moocher
Minnie.the.Moocher is offline
6th Gear
Join Date: Jun 2014
Location: earth PNW
Posts: 4,654
Received 378 Likes on 331 Posts
In defense of piggyback vs ecu tune. If you are going to sell or trade your car, the piggyback can be sold, the ecu tune money is gone.

So far I don't have any issues with the Dinan. I also wonder about OP's letting this issue fester. If I don't get a return email, I assume the employee blew me off, is out sick or no longer with the company. If none of those are the case then something is going on at DINAN. Also didn't they move recently? Something lost in the shuffle?

I've got loads of questions, I may be more p/off than OP.

I'd love to compare the DINAN to the Bytetronik, they need to offer it up as trial-ware some how. Or Mini Vinnie needs to drive out to Oregon so I can test it.
 
  #19  
Old 03-20-2018, 09:42 AM
Mini_Vinnie's Avatar
Mini_Vinnie
Mini_Vinnie is offline
Moderator
iTrader: (1)
Join Date: Feb 2016
Location: Minneapolis, MN
Posts: 1,522
Received 221 Likes on 182 Posts
Originally Posted by Minnie.the.Moocher View Post
Or Mini Vinnie needs to drive out to Oregon so I can test it.
I would go broke at Nike Town
 
  #20  
Old 03-20-2018, 10:32 AM
trentiles
trentiles is offline
4th Gear
Join Date: Apr 2014
Location: Buffalo, NY
Posts: 378
Received 35 Likes on 30 Posts
Originally Posted by TVPostSound View Post
Theres something not right about Dinan's piggyback solution.
Fixed that for you
 
The following users liked this post:
vetsvette (03-21-2018)
  #21  
Old 03-21-2018, 07:20 AM
phantasms's Avatar
phantasms
phantasms is offline
5th Gear
Thread Starter
Join Date: Oct 2007
Location: Bedford, NY
Posts: 719
Received 13 Likes on 11 Posts
Originally Posted by Johras View Post
These are the exact same codes I got with a Dinan Sport, started with just the P12A9 which didn't really affect anything. After a while I started to get the P10F2 code with reduced power.

Haven't had a single code since I removed it.
Too funny. Back when they were still replying to emails they said "wow that's weird we've never had any issue like that before".

Originally Posted by TVPostSound View Post
At this point, you first need to remove the Dinan, including any harness of theirs.
Dont rely on the bypass plug, you want to remove the harness from the equation.

Then clear the codes. Dash Command did not clear my codes either. But a basic hand scanner at AutoZone did.

The lackadaisical responses from Dinan was the sole reason I sent my Elite back for a full refund.

Theres something not right about a piggyback solution.
How did you get refunded? Frankly I haven't reached out to Way about it yet because I was always under the assumption that DINAN would eventually figure it out. My car is a lease and frankly I was willing to not have the very best tune so I could keep the warranty. I want this to work. But at this point F it. Obviously this is way past the return period but I have evidence that it didn't work since day 2.

Best,
Gene
 
  #22  
Old 03-21-2018, 07:41 AM
vetsvette's Avatar
vetsvette
vetsvette is offline
Moderator
iTrader: (5)
Join Date: Oct 2013
Location: South Central Virginia
Posts: 3,794
Received 370 Likes on 290 Posts
Quote:
Originally Posted by TVPostSound
"Theres something not right about Dinan's piggyback solution."

"Fixed that for you"

2 years with a NM Module and never a problem.
 
  #23  
Old 03-21-2018, 07:56 AM
Minnie.the.Moocher's Avatar
Minnie.the.Moocher
Minnie.the.Moocher is offline
6th Gear
Join Date: Jun 2014
Location: earth PNW
Posts: 4,654
Received 378 Likes on 331 Posts
Originally Posted by phantasms View Post
Too funny. Back when they were still replying to emails they said "wow that's weird we've never had any issue like that before".



How did you get refunded? Frankly I haven't reached out to Way about it yet because I was always under the assumption that DINAN would eventually figure it out. My car is a lease and frankly I was willing to not have the very best tune so I could keep the warranty. I want this to work. But at this point F it. Obviously this is way past the return period but I have evidence that it didn't work since day 2.

Best,
Gene
You should reach out to WAY or any other vendor that sells you a product that isn't getting proper support. They need to interface with Dinan and they also need to know that their customer isn't being taken care of.
 
  #24  
Old 03-21-2018, 07:57 AM
phantasms's Avatar
phantasms
phantasms is offline
5th Gear
Thread Starter
Join Date: Oct 2007
Location: Bedford, NY
Posts: 719
Received 13 Likes on 11 Posts
Originally Posted by Minnie.the.Moocher View Post
You should reach out to WAY or any other vendor that sells you a product that isn't getting proper support. They need to interface with Dinan and they also need to know that their customer isn't being taken care of.
Great minds. I literally just sent them an email in hopes that they'll just take it back. I told them I'd pay the shipping for the return and cover their initial shipping costs. We'll see what happens.

Thanks!

Best,
Gene
 
  #25  
Old 03-21-2018, 08:19 AM
Kevinb940
Kevinb940 is offline
1st Gear
Join Date: Jul 2015
Posts: 35
Received 0 Likes on 0 Posts
I have a 16 JCW and have had 3 piggyback units and none of them have ever given me any issues.

NM
Race Chip
JB4

So whatever is happening in your case definitely seems specific to Dinan.

If you are able to get your money back (I hope you can) and you are still wanting a piggyback unit I can recommend any of the 3 above.

The NM was the easiest to install however but the JB4 had the best features and functionality. Plenty of other members on here have had these as well and also liked them.


Let us know how it goes after way gets back with you hopefully he can help.
 

Last edited by Kevinb940; 03-21-2018 at 10:09 AM.

Thread Tools
Search this Thread
Quick Reply: Dinan Elite JCW CEL P12A9 :(


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: