Go Back  North American Motoring > 2nd Generation MINIs > Stock Problems/Issues
R56 service / brake lights etc reset procedure >

R56 service / brake lights etc reset procedure

Stock Problems/Issues Discussions related to warranty related issues and repairs, or other problems with the OEM parts and software for MINI Clubman (R55), Cooper and Cooper S(R56), and Cabrio (R57).

R56 service / brake lights etc reset procedure

  #76  
Old 10-23-2013, 04:04 PM
Lifecycles's Avatar
Lifecycles
Lifecycles is offline
2nd Gear
Join Date: Jan 2013
Location: Southeast Louisiana
Posts: 79
Likes: 0
Received 0 Likes on 0 Posts
I did mine last night and got everything reset on my 08 R56. I let go of the two buttons on the Tach after the symbol and did the BC to change symbols and reset. Once the symbol you want appears hold the button again and a RESET appaers with a little timer by the symbol. I held the BC till it timed out and did the same to the others and it reset.I too had trouble making it reset with both buttond held down while pushing the BC.
 
  #77  
Old 11-11-2013, 03:47 PM
tboogs
tboogs is offline
Neutral
Join Date: Jun 2013
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Light reset for '05

Just replaced front rotors on my '05 and I'm plagued by the ABS light,ASC light and tire warning light. I'd love to know how to reset or troubleshoot.
 
  #78  
Old 11-11-2013, 04:54 PM
Capt_bj
Capt_bj is offline
OVERDRIVE
Join Date: Jul 2006
Location: Melbourne, FL
Posts: 6,377
Received 97 Likes on 87 Posts
search on 'trifecta'

usually a sign that a wheel speed sensor is damaged . . .
 
  #79  
Old 11-15-2013, 11:08 AM
zminicooper's Avatar
zminicooper
zminicooper is offline
1st Gear
Join Date: Apr 2010
Location: Massillon, Ohio
Posts: 34
Likes: 0
Received 0 Likes on 0 Posts
Hello NAM motors. I recently did a brake job (front and rear rotors and pads) about 4 months ago. The dealer wanted to charge me $30 to reset the light, and luckily i ran across this post. However now my rear service brake light came on along with the "BRAKE" light on my tac. I did the reset several times and the same thing happens. It resets to 30k miles and then a day later the service light comes on (message center turns yellow when the car is started up and then after so many miles it turns red and the brake light comes on). Does anyone have any ideas on the problem?
One key point i forgot to mention is that i never fully connected it with the brake pad in the rear. I have it wire tied to one of the rear brake likes so i don't have to buy a sensor again.
Thanks all!
 
  #80  
Old 11-15-2013, 01:07 PM
Capt_bj
Capt_bj is offline
OVERDRIVE
Join Date: Jul 2006
Location: Melbourne, FL
Posts: 6,377
Received 97 Likes on 87 Posts
was the dealer going to charge you $30 for a new sensor?

If your sensor 'tripped' it must be replaced OR you must cut off the end and tie the wire ends together. (then you can wire tie the end out of the way disabling the sensor)

A sensor trips by breaking a wire creating an open circuit.
(a worn sensor with the wire nubs circled .. the rotor wore the connecting wire away, tripping the sensor)
Name:  29726cb3-e422-4202-a709-95a8ada40fbe_zps931fddd8.jpg
Views: 673
Size:  76.3 KB

You must close this open circuit or the system will do what you see - immediately show a worn condition again.

Snip the sensor off the end and connect the wires together. I solder 'em and seal with heat shrink tube.
Name:  100_0026.jpg
Views: 906
Size:  67.5 KB
 
  #81  
Old 11-15-2013, 02:41 PM
zminicooper's Avatar
zminicooper
zminicooper is offline
1st Gear
Join Date: Apr 2010
Location: Massillon, Ohio
Posts: 34
Likes: 0
Received 0 Likes on 0 Posts
The dealer was quoting to turn the brake light off the tachometer. And I bought a new sensor, but from the way you said it, it looks like the sensor was tripped. I'll give the wire-tieing a go.
Thanks!
 
  #82  
Old 11-19-2013, 05:39 PM
Drowninginlust
Drowninginlust is offline
2nd Gear
Join Date: Jul 2013
Posts: 83
Likes: 0
Received 0 Likes on 0 Posts
Soooooooo you guys are doing this the hard way....... its really a lot simpler then this. get in your car and close the door. Put the car in accessory and then cycle through your notifications (Press the button on the blinker) When its displaying the mileage and temp hold the reset butting ( the one on the right) until it changes to the "service menu. then you press the button to cycle through. Hold it to start the reset and then once it says reset let go and hold it down again to confirm the reset. As for the problem with not being able to reset the brake light you need to go through the reset procedure and then immediately turn off accessory and eject the key and turn it back on. It will stay the same once or twice and then the third key cycle it will reset.
 
  #83  
Old 11-24-2013, 10:25 PM
Mini_Love
Mini_Love is offline
Neutral
Join Date: Nov 2013
Location: Roanoke, VA
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Will this also make my coop stop telling me I need to get my 60,000 mile check up? I have had everything checked out, except I didn't take it to a Mini shop (Closest one is in another state) so it still yells at me.
 
  #84  
Old 11-24-2013, 10:26 PM
Drowninginlust
Drowninginlust is offline
2nd Gear
Join Date: Jul 2013
Posts: 83
Likes: 0
Received 0 Likes on 0 Posts
yeah you can reset the vehicle check in this menu
 
  #85  
Old 12-27-2013, 10:23 PM
Island maser's Avatar
Island maser
Island maser is offline
5th Gear
Join Date: Oct 2009
Location: Gig Harbor WA
Posts: 703
Likes: 0
Received 0 Likes on 0 Posts
Thanks guys. Used #59 with the car running. Put my second set of CarboTech X-10 in the front. Love the pads but the quality of there service is questionable at best. First said I had to return because they were wrong. Didn't machine them to take the sensors.
I made sure when I ordered this time that I needed them with sensors. Again they arrive with out them. Lucky I was using a buddies lift and he has equipment. Machined one of the pads out the take the sensor and all was good. Nice to clear the code without going to the dealer. I had to go back after my last oil change as they forgot to reset it. I also had to install I new sensor on the front. $26 at Mini of Scottsdale AZ. Well priced I thought. This was my second set of front X-10's. Since I am using the same pads and all was good there was no need to turn the rotors. I was concerned about thickness but we measured them and the there were still serviceable but they will need to be replaced next time.
 
  #86  
Old 05-23-2015, 08:17 PM
weebad
weebad is offline
Neutral
Join Date: Oct 2014
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Thank You!

Originally Posted by SFMiniguy View Post
Here is a pretty good video of how to reset. I did it on my 2008 and it worked perfectly! The dealer wanted to charge me $60 to reset it.


http://www.youtube.com/watch?v=REyym...eature=related



Thank You so much!!! I put new pads and rotors on today and tried to clear the code with my scanner but I could not. I checked the sensor, I checked... well I checked everything at least four times.

Jump ahead a few hours, It's almost bedtime now and although the brakes worked fine I still had a red light displayed which is causing anxiety. Angry birds with friends isn't helping so I turn to this forum for help in a moment of inspiration. I found your video and reset the warning on the first try!
Twenty minutes later it's lights out, both on my dashboard and next to the bed. Thank You again!
 
  #87  
Old 06-29-2015, 03:39 PM
madmaxxed's Avatar
madmaxxed
madmaxxed is offline
6th Gear
iTrader: (1)
Join Date: Sep 2010
Posts: 1,176
Likes: 0
Received 0 Likes on 0 Posts
I did front and rear pads and rotors along with new sensors in my wife's 2010 MCS. the sensors tripped just before. I did the simplified procedure to reset the lights by entering the service menu and then clicking the right button. The light cleared but then reappeared within a few weeks later. I just checked and noticed only the rear sensors were reset and not the front. I did try this procedure in this thread but couldn't access anything after the light check part. Her car has an airbag light on. Could this be the reason it wouldn't work properly? Will this mess with anything by not following all the way through the steps? I did clear the front sensor with the simplified procedure. Thank you in advance.

Sent from my iPad using NAMotoring
 
  #88  
Old 08-17-2015, 02:16 AM
billas mini
billas mini is offline
Neutral
Join Date: Apr 2015
Location: GUAM
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
My brake light (red) came on today with a little over 27k miles together with a mini on a lift on startup. I tried the reset procedure and it worked at first. Turned the car off and started it again only to find out the the brake and lift light is back on but this time the color is now yellow. Am I doing something wrong here? Tried to do the reset again a few more times to no avail. I have not done the checking of the pads which I can do this coming weekend. If the pads and indicators are worn wouldn't the light continue to be red and not yellow? Please help. Thanks.
 
  #89  
Old 08-18-2015, 01:09 PM
billas mini
billas mini is offline
Neutral
Join Date: Apr 2015
Location: GUAM
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Update: The yellow brake light and the infamous stripper pole magically disappeared while driving today. Don't know what happened but everything seems a-ok.
 
  #90  
Old 08-18-2015, 10:59 PM
Slave to Felines's Avatar
Slave to Felines
Slave to Felines is offline
6th Gear
Join Date: Aug 2011
Location: Silly-con Valley
Posts: 2,058
Likes: 0
Received 3 Likes on 3 Posts
Originally Posted by cmcveay View Post
With the car running, push & hold the RIGHT **** on the tach. ...
Aha! This worked for me where the other song and dance didn't. Well, it did the instrument test, and got me to the VIN menu, but didn't get to the reset. The right-**** thing did!

Thanks, and know that your post is helping someone even seven years later...
 
  #91  
Old 04-05-2016, 09:26 AM
r56turbored
r56turbored is offline
Neutral
Join Date: Apr 2016
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
I just tried to reset my brake light but it won't reset goes into reset mode with the timer but just continues to say original milage that it's over do. -260. Help please
 
  #92  
Old 04-06-2016, 04:15 PM
Slave to Felines's Avatar
Slave to Felines
Slave to Felines is offline
6th Gear
Join Date: Aug 2011
Location: Silly-con Valley
Posts: 2,058
Likes: 0
Received 3 Likes on 3 Posts
Have you replaced the brake pad wear sensor(s)?
 
  #93  
Old 04-06-2016, 07:15 PM
r56turbored
r56turbored is offline
Neutral
Join Date: Apr 2016
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Slave to Felines View Post
Have you replaced the brake pad wear sensor(s)?
I have not I suppose that makes sense huh. I just order some ceramic pads and drilled and slotted rotors for the front. The kit comes with a new sensor!
 
  #94  
Old 04-23-2016, 01:08 PM
R56YouSankMyBattleship
R56YouSankMyBattleship is offline
1st Gear
Join Date: Nov 2015
Location: Vermont
Posts: 16
Likes: 0
Received 0 Likes on 0 Posts
I had the front brake warning on my 2010 Cooper Base Hatchback. I tried resetting from about 1100 miles remaining, but it would never reset. I tried disconnecting and reconnecting the pad wear sensor, but that didn't help. The wear sensor was easily 3/8 of an inch from the rotor, so I didn't think it had worn. Since I had tried everything else with no luck, I figured I had nothing to lose by cutting, stripping, and splicing together the two wires of the sensor. Once I did that and tried the reset procedure again it instantly worked. I think the wear sensor had broken or cracked at some point in it's life and broke the internal circuit, thus it wouldn't allow the computer to be reset.

I tried the OP's procedure for entering the computer, plus the procedure outlined in post 59. Both worked fine for me.
 
  #95  
Old 07-14-2016, 06:04 AM
pluffmud
pluffmud is offline
1st Gear
Join Date: Apr 2016
Location: Edge of America
Posts: 35
Likes: 0
Received 3 Likes on 3 Posts
Reviving - will the seatbelt/airbag indicator override these procedures and render them unworkable? Made it through the dash light check but will not display VIN or cycle to reset.
 
  #96  
Old 07-31-2016, 10:15 PM
LarriB's Avatar
LarriB
LarriB is offline
3rd Gear
Join Date: Dec 2009
Posts: 299
Likes: 0
Received 0 Likes on 0 Posts
I followed these procedures to reset the front brakes, and the reset starts and and shows a little clock like it's thinking, but the brake warning still shows 40 miles, no date. The front and rear brakes and rotors were replaced about 2,000 miles ago.

Any suggestions?

2011 Base hardtop.

TIA.
 
  #97  
Old 08-01-2016, 08:14 AM
DneprDave's Avatar
DneprDave
DneprDave is offline
6th Gear
Join Date: May 2010
Location: Pacific NW
Posts: 3,225
Received 60 Likes on 55 Posts
Did you install new brake wear sensors when you changed the brake pads? There is a sensor on the left front and one on the right rear.

If the brake wear sensor is worn down, they need to be replaced or you can't reset the brake warning light.
 
  #98  
Old 11-15-2016, 02:19 PM
AZdsrt's Avatar
AZdsrt
AZdsrt is offline
6th Gear
Join Date: Jun 2013
Location: Scottsdale, AZ
Posts: 1,446
Received 35 Likes on 33 Posts
2012 R56 - this is what worked for me, took all of 10-20 seconds..

 
The following users liked this post:
dale_z28 (05-06-2019)
  #99  
Old 11-17-2016, 11:09 AM
vistaracer's Avatar
vistaracer
vistaracer is offline
2nd Gear
Join Date: Dec 2013
Location: Colorado
Posts: 58
Likes: 0
Received 0 Likes on 0 Posts
I replaced the front pads and I cut the sensor and soldered the wires together. I have tried to reset with no luck. The display shows the word reset but the little clock icon never appears. Brake light will not go out. Any other ideas?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
igzekyativ
MINIs & Minis for Sale
31
02-07-2019 05:23 PM
oldkid6
R56 :: Hatch Talk (2007+)
25
08-11-2015 08:13 PM
Terry Gallentine
R50/R53 :: Hatch Talk (2002-2006)
4
08-11-2015 03:31 PM
ECSTuning
Vendor Announcements
0
08-07-2015 08:02 AM


Thread Tools
Search this Thread
Quick Reply: R56 service / brake lights etc reset procedure


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: