H&K amp issue resurected - North American Motoring

Navigation & Audio Bring your GPS and favorite CD or MP3. This is where navigation and audio options for the Cooper (R50), Cabrio (R52), and Cooper S (R53) MINIs are discussed.

H&K amp issue resurected

Reply

 
 
 
  #1  
Old 07-30-2018, 06:44 PM
shack0001's Avatar
shack0001
shack0001 is offline
1st Gear
Thread Starter
Join Date: Jun 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
H&K amp issue resurected

Only posts I can find on the POS H&K amp in early R53s are ancient - 10 + years in some cases. Mine died about 18 months ago while Rodan and my daughter were going to college in Cali. Victim of the crappy roads in and around Central CA I'm afraid. I am finally getting ready to tackle this issue.

Question 1: I had the OE unit "rebuilt" (replaced two chips) but still no workie. Is there some sort of dealer reflash required to restore settings or something?

Q 2: A unit with the exact Part number is available on eBay with a pretty hefty price tag. Anyone here parting out an R53 with the H&K system?

Thanks in advance.


tony
 
Reply With Quote
  #2  
Old 07-31-2018, 08:20 AM
gumbedamit
gumbedamit is offline
5th Gear
Join Date: Oct 2016
Location: Atlanta Georgia
Posts: 688
Thanked 49 Times in 46 Posts
Originally Posted by shack0001 View Post
Only posts I can find on the POS H&K amp in early R53s are ancient - 10 + years in some cases. Mine died about 18 months ago while Rodan and my daughter were going to college in Cali. Victim of the crappy roads in and around Central CA I'm afraid. I am finally getting ready to tackle this issue.

Question 1: I had the OE unit "rebuilt" (replaced two chips) but still no workie. Is there some sort of dealer reflash required to restore settings or something?

Q 2: A unit with the exact Part number is available on eBay with a pretty hefty price tag. Anyone here parting out an R53 with the H&K system?

Thanks in advance.


tony
Hey Tony,

Sorry you're having problems with your HK. You might have better luck looking at the vendors here on NAM that are parting out cars and sending them your request.
 
Reply With Quote
  #3  
Old 07-31-2018, 09:28 AM
shack0001's Avatar
shack0001
shack0001 is offline
1st Gear
Thread Starter
Join Date: Jun 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks ! I'll give that a try.

tony
 
Reply With Quote
  #4  
Old 07-31-2018, 09:50 PM
DeadErnie
DeadErnie is offline
1st Gear
Join Date: Nov 2017
Location: Sykesville, Maryland
Posts: 21
Thanked 0 Times in 0 Posts
New HK amps are ridiculously expensive. Used ones are outrageously priced too being that they are all old and certain to fail. I picked up a JL M600/6 amp to replace my dead HK. Hopefully it will stop raining soon so I can try to put it in.

I'm using info from this thread for reference. . . https://www.northamericanmotoring.co...p-failure.html
 
Reply With Quote
  #5  
Old 08-07-2018, 09:02 PM
ItalianJobR53's Avatar
ItalianJobR53
ItalianJobR53 is offline
1st Gear
Join Date: Dec 2017
Location: Houghton, MI (Upper Peninsula)
Posts: 42
Thanked 3 Times in 2 Posts
Originally Posted by DeadErnie View Post
New HK amps are ridiculously expensive. Used ones are outrageously priced too being that they are all old and certain to fail. I picked up a JL M600/6 amp to replace my dead HK. Hopefully it will stop raining soon so I can try to put it in.

I'm using info from this thread for reference. . . https://www.northamericanmotoring.co...p-failure.html
Did you get a chance to test the JL?
My amp failed yesterday too and now I'm looking at my options.
 
Reply With Quote
  #6  
Old 09-13-2018, 09:22 PM
A383Wing's Avatar
A383Wing
A383Wing is offline
3rd Gear
Join Date: Sep 2017
Posts: 241
Thanked 14 Times in 13 Posts
I'm interested in hearing if the JL unit replacement was a success or not..... my HK amplifier is dead also

Bryan
 
Reply With Quote
  #7  
Old 09-13-2018, 10:29 PM
ItalianJobR53's Avatar
ItalianJobR53
ItalianJobR53 is offline
1st Gear
Join Date: Dec 2017
Location: Houghton, MI (Upper Peninsula)
Posts: 42
Thanked 3 Times in 2 Posts
Originally Posted by A383Wing View Post
I'm interested in hearing if the JL unit replacement was a success or not..... my HK amplifier is dead also

Bryan
FYI I ended up buying an used HK amp from ebay for $200.
I bought it from this seller: https://goo.gl/82ufd1
It's been working fine for the last month.
​​I don't think there is an amp in their inventory right now tho.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
TonyMastodon
Stock Problems/Issues
2
10-19-2015 09:59 AM
Ken Cooper
R56 :: Hatch Talk (2007+)
15
03-24-2007 11:44 AM
hppsco
Interior/Exterior
10
05-11-2006 03:48 PM


Thread Tools
Search this Thread
Quick Reply: H&K amp issue resurected


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.