Go Back  North American Motoring > 2nd Generation MINIs > Modifications > Electrical
Faulty BEST version when reading FRM module for 2011 R56 >

Faulty BEST version when reading FRM module for 2011 R56

Electrical For discussions regarding wiring up electrical modifications such as radar detectors, brake light mods, power sockets, and driving lights in Clubman (R55), Cooper and Cooper S (R56), and Cabrio (R57) MINIs.

Faulty BEST version when reading FRM module for 2011 R56

  #1  
Old 05-20-2011, 09:51 PM
NintenTom
NintenTom is offline
4th Gear
Thread Starter
iTrader: (4)
Join Date: Dec 2010
Posts: 376
Likes: 0
Received 0 Likes on 0 Posts
Faulty BEST version when reading FRM module for 2011 R56

Hey guys. I'm trying to access the FRM module but this message always pops up. So far the only successful programming i've done is in the CAS and KOMBI modules, although i also can't get in SKPEG (forgot how to spell it) to complete the heartbeat alarm mod. I'd like to access the FRM module to take out the bulb checks. Any input would be great. I've so far tried v41, v38 datens so far. My INPA and NCS expert versions are the latest ones (from the Complete DIY thread). The message prompt is shown below

 
  #2  
Old 05-23-2011, 08:49 AM
GeoffreyM
GeoffreyM is offline
4th Gear
Join Date: Dec 2010
Location: NOLA
Posts: 502
Likes: 0
Received 0 Likes on 0 Posts
So far I have had no luck with this either, v38, 39, 40 or 41.
 
  #3  
Old 05-23-2011, 07:05 PM
GTECKO's Avatar
GTECKO
GTECKO is offline
3rd Gear
Join Date: Feb 2011
Location: Halifax - Canada
Posts: 266
Likes: 0
Received 5 Likes on 1 Post
I wish I could tell you what to do with the 2011 Mini but I dont have one and cant check for sure...

You had V38 I believed but in order for it to work, the set up I used was the V32 files in the c:\ediabas\ecu folder
and
V38 or V40 for everything else.
I believe the problem is v38/40 for ediabas

try this and let me know.
refer to NCS expert thread so that other members can help too
 
  #4  
Old 05-23-2011, 10:36 PM
NintenTom
NintenTom is offline
4th Gear
Thread Starter
iTrader: (4)
Join Date: Dec 2010
Posts: 376
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by GTECKO View Post
I wish I could tell you what to do with the 2011 Mini but I dont have one and cant check for sure...

You had V38 I believed but in order for it to work, the set up I used was the V32 files in the c:\ediabas\ecu folder
and
V38 or V40 for everything else.
I believe the problem is v38/40 for ediabas

try this and let me know.
refer to NCS expert thread so that other members can help too
The lowest datens i've gotten my hands on is v34. Could you PM me the V32 ones? Thanks.
 
  #5  
Old 05-23-2011, 11:37 PM
Chernobyl's Avatar
Chernobyl
Chernobyl is offline
2nd Gear
Join Date: May 2008
Location: Kelowna BC Canada
Posts: 128
Likes: 0
Received 0 Likes on 0 Posts
I think I've finally come up with the right combination to prevent this error.

The problem comes about from the fact that only complete and installable version of the EDIABAS software available on the net is too old to work with the new datens.

So, here's what to do:
  1. Install NCS Expert/INPA/EDIABAS exactly as laid out in GTECKO's very helpful download and How-To guides.
  2. Update your datens to the latest V41 files.
  3. Download the following file: ftp://94.212.182.18/INPA-EDIABAS/EDIABAS_7_2_0.rar
  4. Make a complete copy of your existing C:\EDIABAS folder into something like C:\EDIABAS.old - just in case. Ensure that you also save a copy of the C:\EDIABAS\BIN\EDIABAS.INI file - you'll need it for step 6.
  5. OVERWRITE the files and directories in your C:\EDIABAS folder with the ones in the RAR file.
  6. Replace the newly extracted EDIABAS.INI file in C:\EDIABAS\BIN with the original version you saved in step 4.
This will upgrade your EDIABAS to version 7.2.0. Using this version I have had no problems reading and coding the various modules in my car (no more BEST version errors).

NOTE: If you also use the GT1/DIS V57 software, then version 7.2.0 of EDIABAS does not appear to work with it. You may need to revert back to the V6.x EDIABAS to use GT1.

Good luck!
 

Last edited by Chernobyl; 05-26-2011 at 01:00 PM. Reason: Added a step to save and restore the ediabas.ini file.
  #6  
Old 05-23-2011, 11:44 PM
NintenTom
NintenTom is offline
4th Gear
Thread Starter
iTrader: (4)
Join Date: Dec 2010
Posts: 376
Likes: 0
Received 0 Likes on 0 Posts
Cool i'll give this a try possibly after finals this wednesdays. I'll need to laden.bat back to v41 and then upgrade the EDIBIAS software to the one you linked. Will report back later.

edit: speaking of which, does anyone know which module and which code to look for to disable the TMPS light and/or sounds?
 
  #7  
Old 05-24-2011, 04:18 PM
GTECKO's Avatar
GTECKO
GTECKO is offline
3rd Gear
Join Date: Feb 2011
Location: Halifax - Canada
Posts: 266
Likes: 0
Received 5 Likes on 1 Post
Could work too Chernobyl. I did try the one you told me (mention in my post above) and never had a problem since.
 
  #8  
Old 05-25-2011, 08:02 PM
NintenTom
NintenTom is offline
4th Gear
Thread Starter
iTrader: (4)
Join Date: Dec 2010
Posts: 376
Likes: 0
Received 0 Likes on 0 Posts
I just tried Chernobyl's method but it doesn't seem to work for me. I ran INPA to wait for the two black dots and couldn't get them to light up no matter what. I tried going straight to NCS expert to try and read the ECU but no go, after selecting the CAS module after selecting R56, i get a VIN FAULTY error.

As for GTECKO's method, i could not try it because i don't have the V32 datens.
 

Last edited by NintenTom; 05-25-2011 at 08:10 PM.
  #9  
Old 05-26-2011, 12:55 PM
Chernobyl's Avatar
Chernobyl
Chernobyl is offline
2nd Gear
Join Date: May 2008
Location: Kelowna BC Canada
Posts: 128
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by NintenTom View Post
I just tried Chernobyl's method but it doesn't seem to work for me. I ran INPA to wait for the two black dots and couldn't get them to light up no matter what. I tried going straight to NCS expert to try and read the ECU but no go, after selecting the CAS module after selecting R56, i get a VIN FAULTY error.
D'oh! When I saw your post I remembered that I forgot to include one step. Keep in mind that when you overwrite the EDIABAS files using the version 7.2.0 archive, one file that gets overwritten is the ediabas.ini file. This important file contains the configuration information for the diagnostic cable connection.

So, you need to grab a copy of the original ediabas.ini file from your original installation (you did keep a backup copy right?) and then use it to replace the file the gets extracted from the .RAR file.

I'm pretty sure that should get the new version up and running (hopefully I haven't forgotten any other steps). I've corrected my original post above to add this step.
 
  #10  
Old 05-26-2011, 01:51 PM
GTECKO's Avatar
GTECKO
GTECKO is offline
3rd Gear
Join Date: Feb 2011
Location: Halifax - Canada
Posts: 266
Likes: 0
Received 5 Likes on 1 Post
hey Chernobyl, why not using the V32 datens replacement like we did for the alarm module mode?
was quicker and it is a small file
 
  #11  
Old 05-26-2011, 09:15 PM
NintenTom
NintenTom is offline
4th Gear
Thread Starter
iTrader: (4)
Join Date: Dec 2010
Posts: 376
Likes: 0
Received 0 Likes on 0 Posts
Woot finally got into the FRM module to disable the bulb checks. I used a combination of both GTECKO's V32 ECU daten files in the C:\EDIABAS\ECU folder along with Chernobyl's copying of the original .INI file to the newer version of EDIABAS to get it working. Thanks guys!
 
  #12  
Old 05-29-2011, 11:21 AM
GeoffreyM
GeoffreyM is offline
4th Gear
Join Date: Dec 2010
Location: NOLA
Posts: 502
Likes: 0
Received 0 Likes on 0 Posts
Mine too! Thanks cherbobyl!!

V41 on R60S all modules!!
 
  #13  
Old 05-29-2011, 06:29 PM
Chernobyl's Avatar
Chernobyl
Chernobyl is offline
2nd Gear
Join Date: May 2008
Location: Kelowna BC Canada
Posts: 128
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by GTECKO View Post
hey Chernobyl, why not using the V32 datens replacement like we did for the alarm module mode?
The main reason I'm suggesting upgrading the EDIABAS version is that it allows you to take advantage of the V41 datens and not have to worry about switching back and forth between datens depending on which ECU you want to read. Prior to updating to 7.2.0 I was unable to find a single combination of datens that would allow me to read everything.

If you're new to coding, the few extra steps above will reduce the overall fear factor associated with the process - and I think that makes it worthwhile. You won't have to worry about switching back and forth between datens or getting cryptic BEST version errors when coding. On that basis, I'd recommend adding it into your How-To instructions, but it's your choice.

Cheers!
 
  #14  
Old 05-30-2011, 11:14 AM
GeoffreyM
GeoffreyM is offline
4th Gear
Join Date: Dec 2010
Location: NOLA
Posts: 502
Likes: 0
Received 0 Likes on 0 Posts
Thanks to everyone who has contributed I managed to code this morning the following:
2011 r60
2009 r56
2008 r56
2011 r56(2 days old!)
2009, 2008 clubbie!!!

Thank you!! Keep coding!!
 
  #15  
Old 05-30-2011, 11:38 AM
GTECKO's Avatar
GTECKO
GTECKO is offline
3rd Gear
Join Date: Feb 2011
Location: Halifax - Canada
Posts: 266
Likes: 0
Received 5 Likes on 1 Post
Sweet
 
  #16  
Old 06-05-2011, 10:30 AM
donuttang
donuttang is offline
3rd Gear
Join Date: Dec 2007
Posts: 164
Likes: 0
Received 0 Likes on 0 Posts
where to get teh V32 daten?
 
  #17  
Old 06-05-2011, 12:35 PM
NintenTom
NintenTom is offline
4th Gear
Thread Starter
iTrader: (4)
Join Date: Dec 2010
Posts: 376
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by donuttang View Post
where to get teh V32 daten?
File name: R56.rar File size: 21.66 MB
 
  #18  
Old 06-06-2011, 04:49 AM
donuttang
donuttang is offline
3rd Gear
Join Date: Dec 2007
Posts: 164
Likes: 0
Received 0 Likes on 0 Posts
thank you everyone, i got the sport button and the mpg stats......yeahhhhhhhhhhhhhh
 
  #19  
Old 07-07-2011, 06:05 PM
Juppers
Juppers is offline
2nd Gear
Join Date: Jun 2011
Posts: 104
Likes: 0
Received 0 Likes on 0 Posts
Where do you find the V41 datens without downloading the 13 gig 3 DVD set?
 
  #20  
Old 07-07-2011, 07:30 PM
NintenTom
NintenTom is offline
4th Gear
Thread Starter
iTrader: (4)
Join Date: Dec 2010
Posts: 376
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Juppers View Post
Where do you find the V41 datens without downloading the 13 gig 3 DVD set?
will upload it for you in a bit.

edit: here ya go (should be 70 something mb when unzipped with 3 folders)
File name: v41_r56.zip File size: 10.46 MB
 
  #21  
Old 07-11-2011, 05:59 PM
Antoine524
Antoine524 is offline
1st Gear
Join Date: Jul 2010
Posts: 18
Likes: 0
Received 0 Likes on 0 Posts
i can't read FRM module :(

I tried 3 different versions : v39, v40, v41 :(
 
  #22  
Old 07-11-2011, 08:53 PM
Juppers
Juppers is offline
2nd Gear
Join Date: Jun 2011
Posts: 104
Likes: 0
Received 0 Likes on 0 Posts
V41 seems to be hit or miss for me. Sometimes it will the modules, but more often than not it fails. I will try it from scratch again soon.
 
  #23  
Old 08-14-2011, 06:29 PM
TiggerGTO
TiggerGTO is offline
3rd Gear
Join Date: Jan 2011
Posts: 152
Likes: 0
Received 0 Likes on 0 Posts
I had to copy all the .INI files from my old C:\EDIABAS\BIN directory to my new one after laying down this new version. When I only copied the old EDIABAS.INI file, I got the VIN FAULTY error. After copying all the .INI files, it worked.
 
  #24  
Old 08-15-2011, 09:31 PM
Juppers
Juppers is offline
2nd Gear
Join Date: Jun 2011
Posts: 104
Likes: 0
Received 0 Likes on 0 Posts
I have a 2008 S, and none of the combinations listed in this thread work. Any suggestions on where to go from here? I've tried v38, v41, v32, all of them with 6.x and 7.2 of ediabas. I'm trying to default the car so my new VO with the rear fog lights will take effect. Or if anyone knows which modules I need to reset singularly, that would be great too.
 
  #25  
Old 08-16-2011, 04:23 PM
Juppers
Juppers is offline
2nd Gear
Join Date: Jun 2011
Posts: 104
Likes: 0
Received 0 Likes on 0 Posts
I guess i reset enough modules cause now the rear fogs work.
 

Thread Tools
Search this Thread
Quick Reply: Faulty BEST version when reading FRM module for 2011 R56


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: