Go Back  North American Motoring > 1st Generation MINIs > Stock Problems/Issues
04 r53 front wipers won't stop working >

04 r53 front wipers won't stop working

Stock Problems/Issues Discussions related to warranty related issues and repairs, or other problems with the OEM parts and software for MINI Cooper (R50), Cabrio (R52), and Cooper S (R53) MINIs.
Sponsored by:
Sponsored by:

04 r53 front wipers won't stop working

  #1  
Old 09-13-2015, 11:38 AM
laf04mcs
laf04mcs is offline
Neutral
Thread Starter
Join Date: Sep 2015
Location: lafayette, Indiana
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
04 r53 front wipers won't stop working

Hi everyone new i am new to this group hopefully this is in the right place.

so about 3 weeks ago i purchased an 04 r53 and everything was working great on it till i went to go take it out the battery was dead i got it jump started and everything seemed fine. It ended up going to a mechanic and getting the ignition and power steering pump replaced. After that i noticed my wipers wouldn't turn on and i started checking things and found that the relay was unplugged for some reason. So i put it back in with the car off and the wipers started going and would't stop and has been like that for well over a week now.

I have been looking everywhere i can online even ordered new relays which hopefully will be here in a week, but still can't find any concrete fix or diagnosis as to what could be wrong. I have read about people undoing the battery terminals and unplugging the body control unit and for some it seemed to work and others it was temporary. i have checked all my fuses that have anything to do with the front wipers and they are all good i even replaced them just to make sure. I checked voltage at the first front wiper relay with the car off and it has 12v going through it constantly.

So that is basically where i am at with the car the stalk has no control over the front wipers, but the rear works fine. I love the car, but the closest Mini dealership is well over an hour away.

If any one has any insight as to what i could try i would appreciate it.
 
  #2  
Old 09-13-2015, 01:57 PM
Hobine
Hobine is offline
1st Gear
Join Date: Aug 2015
Location: MA
Posts: 36
Likes: 0
Received 0 Likes on 0 Posts
Similar problem here on an 04 MCS, sorry I can't help at this point. For me it's the rear wiper that has a mind of its own. When it decides to run, with no input from me, the stalk has no control over it. It stops when it feels like stopping, on its own. I lost my washers at the same time this started happening.
I did replace the stalk on mine, but that didn't make any difference.
 
  #3  
Old 09-13-2015, 04:41 PM
jacobj
jacobj is offline
1st Gear
Join Date: Aug 2015
Posts: 46
Likes: 0
Received 2 Likes on 1 Post
The mechanic you took the car to seems to be the one you need to question.
Sounds like they did the work on your car and realized the wipers wouldn't turn off, and unplugged the relay so that you wouldn't notice right away and start questioning.

I'd get in touch with the mechanic.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
igzekyativ
MINIs & Minis for Sale
31
02-07-2019 05:23 PM
silence2-38554
R50/R53 :: Hatch Talk (2002-2006)
3
11-12-2015 09:39 AM
Wohnson89
R50/R53 :: Hatch Talk (2002-2006)
3
09-25-2015 04:00 PM
ECSTuning
Vendor Announcements
0
08-07-2015 08:02 AM
ECSTuning
Interior/Exterior Products
0
08-07-2015 05:56 AM


Thread Tools
Search this Thread
Quick Reply: 04 r53 front wipers won't stop working


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.