Fuel filter replacement/starting issue - North American Motoring

Go Back  North American Motoring > 1st Generation MINIs > Stock Problems/Issues
Fuel filter replacement/starting issue >

Fuel filter replacement/starting issue

Stock Problems/Issues Discussions related to warranty related issues and repairs, or other problems with the OEM parts and software for MINI Cooper (R50), Cabrio (R52), and Cooper S (R53) MINIs.
Sponsored by:
Sponsored by:

Fuel filter replacement/starting issue

Reply

 
 
 
  #1  
Old 07-13-2018, 05:47 PM
cooper48's Avatar
cooper48
cooper48 is offline
2nd Gear
Thread Starter
Join Date: Jul 2018
Location: DFW
Posts: 78
Thanked 5 Times in 5 Posts
Fuel filter replacement/starting issue

Hi, all.

I replaced the fuel filter on my 2004 MC40 today and now cannot start the car. In addition to the filter, I replaced all the appropriate o-rings and seals. It turns over just fine but was emitting "clicking" noises from the fuel filter area when reassembled. Thinking that the battery may have lost power (recharged from 12.3v to 12.8v after one hour), I charged the battery since I had the doors open when working. Nada.

I've removed the fuel filter twice to examine it. Found nothing wrong (again). Now when priming the pump in ignition position 2, I'm no longer getting the clicking sounds heard earlier (immediately after the initial installation), yet it still won't start. I removed the fuel line to the filter and there is no fuel leaking from the hose when removed, i.e., doesn't seem to have line pressure?

The car is throwing NO codes. I've seen some threads with the same starting issue after filter replacement. Next step would be to remove the inspection plate over the fuel pump and check for pressure there but I would like to avoid that if possible. I didn't disconnect the neg terminal on the battery when replacing the filter. Could that have compromised the actual fuel pump in some way?

How about the fuel rail? Do I need to remove the intercooler to access it (I'm a Mini newbie)?

Anyone have a solution? I'm a competent mechanic but this is extremely frustrating (maybe it's a Mini thing)!!!
 
Reply With Quote
  #2  
Old 07-16-2018, 05:23 AM
minsanity's Avatar
minsanity
minsanity is offline
6th Gear
Join Date: Aug 2009
Posts: 1,487
Thanks: 0
Thanked 9 Times in 9 Posts
Read this carefully....
https://www.pelicanparts.com/techart...eplacement.htm

This particular paragraph:
"Take the upper cover and carefully line up the tabs on it (it can only go in one way) with the tabs on the lower filter housing. Take care to make sure the upper cover is directly seated on the filter element. If it isn't, THE CAR WON'T START. We found this out the hard way after re-assembling the fuel system. Once the upper cover is seated, rotate it clockwise until it stops. This will lock it in place."
 
Reply With Quote
The Following User Says Thank You to minsanity For This Useful Post:
cooper48 (07-16-2018)
  #3  
Old 07-16-2018, 05:26 AM
Whine not Walnuts's Avatar
Whine not Walnuts
Whine not Walnuts is offline
OVERDRIVE
Join Date: Mar 2013
Location: Fuquay Varina, NC
Posts: 5,526
Thanked 598 Times in 539 Posts
Moving you to the Stock Problems/Issues section.

Is there gas coming out the rail?
 
Reply With Quote
  #4  
Old 07-16-2018, 07:48 AM
cooper48's Avatar
cooper48
cooper48 is offline
2nd Gear
Thread Starter
Join Date: Jul 2018
Location: DFW
Posts: 78
Thanked 5 Times in 5 Posts
Thanks for all the responses everyone. Minsanity had the solution.

I pulled the filter housing (yet again) and the top was not fully and correctly seated. Fixed that, primed it three times and it started right up. Thanks Minsanity!!!
 
Reply With Quote
  #5  
Old 07-16-2018, 02:46 PM
minsanity's Avatar
minsanity
minsanity is offline
6th Gear
Join Date: Aug 2009
Posts: 1,487
Thanks: 0
Thanked 9 Times in 9 Posts
Anytime, sir! Glad it's fixed.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
PhoR53
Stock Problems/Issues
9
10-12-2018 06:26 AM
G3NSM0R3S
R60 :: Countryman Talk (2010-2015)
12
10-03-2016 09:32 PM
y8s
R60/R61 Stock Problems/Issues
65
12-05-2014 03:14 PM
junior
R50/R53 :: Hatch Talk (2002-2006)
0
12-22-2012 08:18 PM
rynegold
R50/R53 :: Hatch Talk (2002-2006)
0
04-02-2009 07:13 PM


Thread Tools
Search this Thread
Quick Reply: Fuel filter replacement/starting issue


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.