Confused on BimmerCode and my F60 Tail Lights - North American Motoring

Go Back  North American Motoring > MINI Countryman (2010 +) > F60 :: Countryman Talk (2016+)
Confused on BimmerCode and my F60 Tail Lights >

Confused on BimmerCode and my F60 Tail Lights

F60 :: Countryman Talk (2016+) F60 Cooper and Cooper S hatchback discussion NOT REPAIR RELATED Discussions.

Confused on BimmerCode and my F60 Tail Lights

Reply

 
 
 
  #1  
Old 03-12-2018, 01:39 PM
AnOldBiker
AnOldBiker is offline
4th Gear - An Official NAM Greeter
Thread Starter
Join Date: Sep 2017
Posts: 980
Thanked 138 Times in 134 Posts
Confused on BimmerCode and my F60 Tail Lights

Ok, I'm as confused as all get out. I installed LED (canbus) lights from superbrightleds.com for my F60 tail lights and set my coding with the BimmerCode App to show LED and shut off the checks for all the lights. I checked all the lights to make sure they work and they do. Brighter than the light weight halogen bulbs. Reinstalled the light brackets. Checked for proper function and they worked perfect.

But soon after, when I checked the dash, it says the left brake light is out. Checked and they are fine. I even pulled the light unit out and all lights checked fine.

Then the dash said the right side is out. Checked the same and they are all fine. Checked the dash again and it was the left light out again.

Seems to rotate but still shows lights on one or the other side is out ... but function as they should.

Any ideas to correct this ?

 

Last edited by AnOldBiker; 03-12-2018 at 04:58 PM.
Reply With Quote
  #2  
Old 03-13-2018, 07:02 AM
darex
darex is offline
5th Gear
Join Date: Feb 2005
Posts: 817
Thanked 17 Times in 17 Posts
Originally Posted by AnOldBiker
Ok, I'm as confused as all get out. I installed LED (canbus) lights from superbrightleds.com for my F60 tail lights and set my coding with the BimmerCode App to show LED and shut off the checks for all the lights. I checked all the lights to make sure they work and they do. Brighter than the light weight halogen bulbs. Reinstalled the light brackets. Checked for proper function and they worked perfect.

But soon after, when I checked the dash, it says the left brake light is out. Checked and they are fine. I even pulled the light unit out and all lights checked fine.

Then the dash said the right side is out. Checked the same and they are all fine. Checked the dash again and it was the left light out again.

Seems to rotate but still shows lights on one or the other side is out ... but function as they should.

Any ideas to correct this ?

I only swapped out my reverse lights, but haven't had any issues. Did you change the brake and/or turn signal bulbs too?
 
Reply With Quote
  #3  
Old 03-13-2018, 07:11 AM
AnOldBiker
AnOldBiker is offline
4th Gear - An Official NAM Greeter
Thread Starter
Join Date: Sep 2017
Posts: 980
Thanked 138 Times in 134 Posts
Yes, I changed out all 8 lights. Nothing with the reverse lights, they appear fine. But the problem is with the brake lights.

The ones I put in were the LED equlivant to the original lights, only red in color to make it more intense. And as stated, with the bulb holder in or out of the housing, they work great and bright. Just the notification on the dash.

I went as far as putting the bimmercode settings back to bulb and activate the sensors. The took off one at a time to see if I had to code it this way ... nothing changed.

Did this with my front lights, changed settings all at once and no problem. I'm sort of confused.
 
Reply With Quote
  #4  
Old 03-13-2018, 07:24 AM
Minnie.the.Moocher's Avatar
Minnie.the.Moocher
Minnie.the.Moocher is online now
6th Gear
Join Date: Jun 2014
Location: earth PNW
Posts: 4,064
Thanked 247 Times in 226 Posts
Warm and cold checks off I assume?
Defective LED's?
 
Reply With Quote
  #5  
Old 03-13-2018, 07:36 AM
AnOldBiker
AnOldBiker is offline
4th Gear - An Official NAM Greeter
Thread Starter
Join Date: Sep 2017
Posts: 980
Thanked 138 Times in 134 Posts
Warm and cold checks are off.
If the LED's are defective, I don't know, due to each working as they should everytime I activate the light. (ie: step on the brake, use the turn signal and such)
 
Reply With Quote
  #6  
Old 03-13-2018, 11:55 AM
trentiles
trentiles is offline
4th Gear
Join Date: Apr 2014
Location: Buffalo, NY
Posts: 378
Thanked 35 Times in 30 Posts
Maybe that coding doesn't work on the F60 yet with bimmercode? Just tossing out idea's.
 
Reply With Quote
  #7  
Old 03-13-2018, 01:16 PM
AnOldBiker
AnOldBiker is offline
4th Gear - An Official NAM Greeter
Thread Starter
Join Date: Sep 2017
Posts: 980
Thanked 138 Times in 134 Posts
Well the BimmerCode works on the F60 since I changed out all the front lights to LED's and haven't had a problem. But now I have a bigger problem. Seems my fat hands broke a locking part inside and now I have to buy a new right tail light housing before I go further. Tried to fix but couldn't.

What I didn't understand was what seemed like a rotation of the the problem. Not gonna worry about it until I get the new light and see if it happens again. Never had this issue before, eveything went without a hitch. Gonna be an expensive fix I guess.
 
Reply With Quote
  #8  
Old 03-14-2018, 06:12 AM
MrFunk's Avatar
MrFunk
MrFunk is offline
4th Gear
Join Date: Mar 2016
Location: Upper Midwest
Posts: 309
Thanked 16 Times in 16 Posts
Keep us posted. I'd like to swap out to LED's too but not if it's going to be a PITA.
 
Reply With Quote
  #9  
Old 03-14-2018, 07:04 AM
AnOldBiker
AnOldBiker is offline
4th Gear - An Official NAM Greeter
Thread Starter
Join Date: Sep 2017
Posts: 980
Thanked 138 Times in 134 Posts
For the halogen conversion to the LED headlights, Daytime Running lights and Parking lights on the front was very easy. Just make sure you use the BimmerCode App and set for LED instead of bulb and turn off the cold and warm checks. That was the easy part.

My problem is in the tail lights. I'm not sure what is happening. Also having large hands don't help much since the hole they give you to get the bulb holder out is for a small person to work with. If doing this, please use caution. I found out late yesterday the driver side rear tail light unit is only available threw Mini and is $210.00 with a 3 day wait for it to be shipped in. Did not have any warnings with the back up lights, just the warning of the stop light. There was no flashing, lights worked as they should, bright in brilliance, just the dash warning. That has me confused. Also, I did check they were CanBus so that isn't the issue. Will beable to do more Friday when the part coes in.

I will say I am very very very happy with the front lighting. Now just the back.
 
Reply With Quote
  #10  
Old 03-16-2018, 01:18 PM
AnOldBiker
AnOldBiker is offline
4th Gear - An Official NAM Greeter
Thread Starter
Join Date: Sep 2017
Posts: 980
Thanked 138 Times in 134 Posts
Well here's what I found out. The bulbs from SuperBrightLEDs.com are:

Red: 130 Ma
White: 230 Ma

But the problem:
1. All are CanBus.
2. The whites draw enough to satisfy the computer with the BimmerCode adjustments.
3. The Red is still to low of a draw that it sends the notice of bulb is out.

So I need to figure out if I put in all White LED's, the red lens might be a pale red or towards a pink. Or go back to bulbs. Sent in for some more whites (only $9.?? each) to see what will happen to the color ... and decide what I will accept.
 
Reply With Quote
  #11  
Old 03-17-2018, 12:48 PM
darex
darex is offline
5th Gear
Join Date: Feb 2005
Posts: 817
Thanked 17 Times in 17 Posts
Originally Posted by AnOldBiker
Well here's what I found out. The bulbs from SuperBrightLEDs.com are:

Red: 130 Ma
White: 230 Ma

But the problem:
1. All are CanBus.
2. The whites draw enough to satisfy the computer with the BimmerCode adjustments.
3. The Red is still to low of a draw that it sends the notice of bulb is out.

So I need to figure out if I put in all White LED's, the red lens might be a pale red or towards a pink. Or go back to bulbs. Sent in for some more whites (only $9.?? each) to see what will happen to the color ... and decide what I will accept.
Find a higher-output red LED, that draws more, or put an in-line resistor and switch code back to "bulb" ??
 
Reply With Quote
  #12  
Old 03-17-2018, 01:02 PM
AnOldBiker
AnOldBiker is offline
4th Gear - An Official NAM Greeter
Thread Starter
Join Date: Sep 2017
Posts: 980
Thanked 138 Times in 134 Posts
I know of using the in-line resistors, but I'm staying away from all that mess. Trying to keep it clean looking. So far I have done everything with what I bought and the BimmerCode App. Just hard finding the right Ma's in red. .
 
Reply With Quote
  #13  
Old 03-20-2018, 12:02 PM
AnOldBiker
AnOldBiker is offline
4th Gear - An Official NAM Greeter
Thread Starter
Join Date: Sep 2017
Posts: 980
Thanked 138 Times in 134 Posts
Well with the red LED's (130Ma) and the white LED's (230Ma), both worked properly .. and still got the warnings on the dash.

So the bulbs are back in and I guess to BimmerCode App asking them what might be the issue or what correction I can take, outside of in-line resistors.

Maybe more to come .. unless someone has an answer for this.
 
Reply With Quote
  #14  
Old 03-20-2018, 01:13 PM
AnOldBiker
AnOldBiker is offline
4th Gear - An Official NAM Greeter
Thread Starter
Join Date: Sep 2017
Posts: 980
Thanked 138 Times in 134 Posts
Well this was their answer:

Hi Jim,
you may be able to fix this with the app using expert mode, but I do not know the exact coding values required in this case honestly.

Schöne Grüße / Kind regards
Stephan Gauch

BimmerCode App
Stephan Gauch




So, your guess is better then mine ....
 
Reply With Quote
  #15  
Old 04-09-2018, 01:45 PM
Mini03Tiger84's Avatar
Mini03Tiger84
Mini03Tiger84 is offline
4th Gear
Join Date: Aug 2003
Location: Waynesville, NC
Posts: 422
Thanked 3 Times in 3 Posts
Hi Jim,
I found this rolled MINI F60 the other day looking an upgrade to the rear-view mirror.
Thy may still have the rear light assembly that would be much cheaper than dealer.

Auto salvage site - http://mandmautosalvage.com/newarrivals.htm

Photos of F60
https://cpprohomeky.car-part.com/ima...ck%23%20170857
 
Reply With Quote
  #16  
Old 04-09-2018, 02:29 PM
AnOldBiker
AnOldBiker is offline
4th Gear - An Official NAM Greeter
Thread Starter
Join Date: Sep 2017
Posts: 980
Thanked 138 Times in 134 Posts
146 miles on the clock, that poor owner must be depressed (if not drunk) right now.

To late, bought the tail light assembly and it was just over $200. But this would have been a $$$ saver if it was a bit earlier .. Thanks.

Still trying to figure how to get the LED's in the back. But going to do a cross country trip in my Mini soon, so it this change will have to wait for now.
 
Reply With Quote
  #17  
Old 04-09-2018, 09:37 PM
18cmjcw
18cmjcw is offline
2nd Gear
Join Date: Jan 2018
Location: SF Bay Area
Posts: 51
Thanked 20 Times in 17 Posts
Originally Posted by AnOldBiker View Post
146 miles on the clock, that poor owner must be depressed (if not drunk) right now.
I know this is off topic, but your comment got me curious, so I tested my online searching... turns out the car had been purchased by IIHS for destructive testing, and shows up on a list of vehicles headed for salvage following that testing. From the looks of the photos on the salvage site, it appears IIHS may have T-boned it on purpose.
http://www.iihs.org/iihs/faq/salvaged-vins
 
Reply With Quote
The Following User Says Thank You to 18cmjcw For This Useful Post:
Mini03Tiger84 (04-10-2018)
  #18  
Old 04-10-2018, 10:32 AM
Crossingover's Avatar
Crossingover
Crossingover is offline
2nd Gear
Join Date: Mar 2018
Posts: 65
Thanked 4 Times in 4 Posts
Originally Posted by 18cmjcw View Post
I know this is off topic, but your comment got me curious, so I tested my online searching... turns out the car had been purchased by IIHS for destructive testing, and shows up on a list of vehicles headed for salvage following that testing. From the looks of the photos on the salvage site, it appears IIHS may have T-boned it on purpose.
http://www.iihs.org/iihs/faq/salvaged-vins
All the salvage vehicles in that list have just hundreds of miles on them.
 
Reply With Quote
  #19  
Old 04-10-2018, 10:34 AM
Crossingover's Avatar
Crossingover
Crossingover is offline
2nd Gear
Join Date: Mar 2018
Posts: 65
Thanked 4 Times in 4 Posts
Originally Posted by AnOldBiker View Post
Still trying to figure how to get the LED's in the back.
Perhaps BMW is in the same boat on this F60 upgrade. I was disappointed they cut costs in the lighting department on the 2018's, but I'm not going to let a few bulbs get in the way of enjoying the ride!
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
TVPostSound
F55/F56 :: Hatch Talk (2014+)
90
10-07-2018 06:14 PM
vetsvette
3rd Gen FAQs
186
10-04-2018 08:17 AM
BazV
F54 :: Clubman Talk (2015+)
135
01-21-2018 02:27 PM
Dimitris Sofianopoulos
Navigation & Audio
3
09-22-2015 03:07 PM


Thread Tools
Search this Thread
Quick Reply: Confused on BimmerCode and my F60 Tail Lights


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: