Mini Charging System - North American Motoring
MINI Cooper MINI Cooper specs

Go Back   North American Motoring > 1st Generation MINIs > R50/R53 :: Hatch Talk (2002-2006)
Log In 
Search


Welcome to North American Motoring !
Welcome to North American Motoring,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Mini Charging System

Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread
  #1  
Old 03-21-2010, 03:05 PM
MiniFixx MiniFixx is offline
1st Gear
 
Join Date: Mar 2010
Posts: 22
Feedback Score: 0 reviews
Mini Charging System

HI all this is my first post, Im sure it wont be my last . I love this car, but realized that my mini was no longer charging its battery, I stuck a VOM on it and read, like 10V when it was running.

I replaced the alternator, thats the first thing I thought of and still no joy. Still the battery light is lit and the battery doesnt charge, does anyone know more about the charging system that could suggest something else that could be wrong. I was SO sure that the new alternator would fix it, but no dice.

I have also verified both wires from the little gang plug to the harness thing attached to the little block was ok. So not really sure what my next step is besides put the old alternator back in it and tow it to the mini dealer.

anyone with thoughts on what else could be wrong would be a great help.

thanks
Wayne
Reply With Quote
  #2  
Old 03-21-2010, 03:18 PM
ofioliti's Avatar
ofioliti ofioliti is offline
6th Gear
 
Join Date: Sep 2003
Location: Always curious ...
Posts: 2,273
Feedback Score: 0 reviews
Welcome, Wayne. How old is the battery?
__________________
http://i94.photobucket.com/albums/l116/ofioliti/NAM%20sig/Presentation1.jpg
'04 MCS "Blue Meanie" / WMW 15% pulley / one-ball exhaust / DDM intake / H-Sport 19 mm anti-sway bar / JCW plugs / Kingsborne wires / magnetic drain plugs / Speedy wheels / Hawk pads + ATI rotors / Craven ST defenders / Whalen shift **** / Scan Gauge II / Gominigo 3rd brake light / Powerflex LCA bushings / WMW street tune / TSW jack points / Ian Cull v. 7 auto-up switch
Reply With Quote
  #3  
Old 03-21-2010, 03:30 PM
MiniFixx MiniFixx is offline
1st Gear
 
Join Date: Mar 2010
Posts: 22
Feedback Score: 0 reviews
thanks! this seems like a cool group from all that I have been reading so far. The battery is new, 7/09

thanks,
Wayne
Reply With Quote
  #4  
Old 03-21-2010, 03:36 PM
daflake's Avatar
daflake daflake is offline
6th Gear
 
Join Date: Sep 2005
Location: Laurel MD
Posts: 3,926
Feedback Score: 0 reviews
The only other thing I can think of is to check the grounding strap. On the S it is on the left side of the engine bay (big black cable). Mine broke and the car wouldn't even start.
Reply With Quote
  #5  
Old 03-21-2010, 04:51 PM
MiniFixx MiniFixx is offline
1st Gear
 
Join Date: Mar 2010
Posts: 22
Feedback Score: 0 reviews
yeah, its definately good, I had to bend it a bit to allow for the tensioner to be let off.

thanks,
Wayne
Reply With Quote
  #6  
Old 03-21-2010, 05:14 PM
CHKMINI CHKMINI is offline
6th Gear
 
Join Date: Jul 2006
Location: Over at the other site
Posts: 1,604
Feedback Score: 0 reviews
Check the jump start stud under the hood. If it is loose or needs cleaned it will affect both voltage reads and charging. It's near the firewall on the left side of the car.
__________________
Reply With Quote
  #7  
Old 03-21-2010, 07:53 PM
MiniFixx MiniFixx is offline
1st Gear
 
Join Date: Mar 2010
Posts: 22
Feedback Score: 0 reviews
Thanks, Ill check that out tomorrow, is there a way to check with a VOM if the alternator is actually putting out the voltage?

I suppose its possible that the new alternator could be bad, its a remanufactured one.

Wayne
Reply With Quote
 
 
 
submit to reddit
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 07:25 AM.



Powered by vBulletin and vBulletin Plugins by Drive Thru Online, Inc.
North American Motoring is an independently operated web site supporting MINI owners and enthusiastsworldwide. As such it has no official relationship with MINI USA, BMW AG, or BMW of North America.All original artwork and design is Copyright © 2002-2004 North American Motoring.
Admin Account Passwords